aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2011-02-13 23:04:20 +0800
committerromain <romain@FreeBSD.org>2011-02-13 23:04:20 +0800
commit81e73409dafe56e823f2bc5dbb15d73d7aa4197b (patch)
tree31977e3e2188f01a9d6585f2efcffa7d4572126c /graphics
parent5517a58b91fa32867708f53b4c1c2da7266537a2 (diff)
downloadfreebsd-ports-gnome-81e73409dafe56e823f2bc5dbb15d73d7aa4197b.tar.gz
freebsd-ports-gnome-81e73409dafe56e823f2bc5dbb15d73d7aa4197b.tar.zst
freebsd-ports-gnome-81e73409dafe56e823f2bc5dbb15d73d7aa4197b.zip
Mscgen is a small program that parses Message Sequence Chart descriptions and
produces PNG, SVG, EPS or server side image maps (ismaps) as the output. WWW: http://www.mcternan.me.uk/mscgen/
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/mscgen/Makefile34
-rw-r--r--graphics/mscgen/distinfo2
-rw-r--r--graphics/mscgen/pkg-descr4
-rw-r--r--graphics/mscgen/pkg-plist13
5 files changed, 54 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9c1093d50d10..8c924d7077ab 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -564,6 +564,7 @@
SUBDIR += mmrecover
SUBDIR += morpheus
SUBDIR += moth
+ SUBDIR += mscgen
SUBDIR += mtpaint
SUBDIR += multivideo
SUBDIR += mupdf
diff --git a/graphics/mscgen/Makefile b/graphics/mscgen/Makefile
new file mode 100644
index 000000000000..0ee9fc7864ed
--- /dev/null
+++ b/graphics/mscgen/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mscgen
+# Date created: 2011-01-23
+# Whom: Romain Tartiere <romain@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mscgen
+PORTVERSION= 0.19
+CATEGORIES= graphics
+MASTER_SITES= http://www.mcternan.me.uk/mscgen/software/ \
+ http://romain.blogreen.org/distfiles/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= romain@FreeBSD.org
+COMMENT= A Message Sequence Chart Renderer
+
+OPTIONS= PNG "Enable PNG support" on
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_PNG)
+CONFIGURE_ARGS+=--with-png
+LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+.else
+CONFIGURE_ARGS+=--without-png
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GNU_CONFIGURE= yes
+
+MAN1= mscgen.1
+
+.include <bsd.port.mk>
diff --git a/graphics/mscgen/distinfo b/graphics/mscgen/distinfo
new file mode 100644
index 000000000000..4eeac630843c
--- /dev/null
+++ b/graphics/mscgen/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mscgen-src-0.19.tar.gz) = f0b77f79c780ed85a6eb299da153cf89442a6880ba6098b4af8e6380ccd33305
+SIZE (mscgen-src-0.19.tar.gz) = 203087
diff --git a/graphics/mscgen/pkg-descr b/graphics/mscgen/pkg-descr
new file mode 100644
index 000000000000..7c2519d6ef9c
--- /dev/null
+++ b/graphics/mscgen/pkg-descr
@@ -0,0 +1,4 @@
+Mscgen is a small program that parses Message Sequence Chart descriptions and
+produces PNG, SVG, EPS or server side image maps (ismaps) as the output.
+
+WWW: http://www.mcternan.me.uk/mscgen/
diff --git a/graphics/mscgen/pkg-plist b/graphics/mscgen/pkg-plist
new file mode 100644
index 000000000000..a6fe7aa42c5a
--- /dev/null
+++ b/graphics/mscgen/pkg-plist
@@ -0,0 +1,13 @@
+@comment $FreeBSD$
+bin/mscgen
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/README
+%%DOCSDIR%%/examples/boxes_example.msc
+%%DOCSDIR%%/examples/client_server.msc
+%%DOCSDIR%%/examples/colour_sample.msc
+%%DOCSDIR%%/examples/msg_types.msc
+%%DOCSDIR%%/examples/simple_prog_desc.msc
+%%DOCSDIR%%/mscgen.lang
+@dirrm %%DOCSDIR%%/examples
+@dirrm %%DOCSDIR%%