aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-01-09 19:11:59 +0800
committerkwm <kwm@FreeBSD.org>2015-01-09 19:11:59 +0800
commit82d8f6e2d0b67eaeb636c26cd46a35efeba20110 (patch)
tree9310be5de9991f0154b6c4d0562a08fac28f2c9b /graphics
parent46820dff98c6d7a7a997ff10cd2eec750f248c04 (diff)
downloadfreebsd-ports-gnome-82d8f6e2d0b67eaeb636c26cd46a35efeba20110.tar.gz
freebsd-ports-gnome-82d8f6e2d0b67eaeb636c26cd46a35efeba20110.tar.zst
freebsd-ports-gnome-82d8f6e2d0b67eaeb636c26cd46a35efeba20110.zip
Make py3-cairo build with python 3.4.
Submitted by: antoine@
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py3-cairo/Makefile5
-rw-r--r--graphics/py3-cairo/files/pycairo-1.10.0-waf-py3_4.patch11
2 files changed, 16 insertions, 0 deletions
diff --git a/graphics/py3-cairo/Makefile b/graphics/py3-cairo/Makefile
index 363444499fc1..a2a5b3041de2 100644
--- a/graphics/py3-cairo/Makefile
+++ b/graphics/py3-cairo/Makefile
@@ -29,6 +29,11 @@ post-patch:
${WRKSRC}/test/examples_test.py
do-configure:
+# Run waf configure twice, once to extract waflib and patch and then actual configure
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${PYTHON_CMD} \
+ ./waf configure || :
+ @cd ${WRKSRC}/.waf3-1.6.4-e3c1e08604b18a10567cfcd2d02eb6e6/ && \
+ ${PATCH} -p1 < ${FILESDIR}/pycairo-1.10.0-waf-py3_4.patch
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${PYTHON_CMD} \
./waf configure
diff --git a/graphics/py3-cairo/files/pycairo-1.10.0-waf-py3_4.patch b/graphics/py3-cairo/files/pycairo-1.10.0-waf-py3_4.patch
new file mode 100644
index 000000000000..6e79db9ba272
--- /dev/null
+++ b/graphics/py3-cairo/files/pycairo-1.10.0-waf-py3_4.patch
@@ -0,0 +1,11 @@
+--- a/waflib/Tools/python.py
++++ b/waflib/Tools/python.py
+@@ -169,7 +169,7 @@
+ conf.find_program('python-config-%s'%num,var='PYTHON_CONFIG',mandatory=False)
+ includes=[]
+ if conf.env.PYTHON_CONFIG:
+- for incstr in conf.cmd_and_log(conf.env.PYTHON+[conf.env.PYTHON_CONFIG,'--includes']).strip().split():
++ for incstr in conf.cmd_and_log([conf.env.PYTHON_CONFIG,'--includes']).strip().split():
+ if(incstr.startswith('-I')or incstr.startswith('/I')):
+ incstr=incstr[2:]
+ if incstr not in includes: