aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-10-28 13:04:41 +0800
committerjbeich <jbeich@FreeBSD.org>2018-10-28 13:04:41 +0800
commit83d982230099c0d0fba8e4194bdc290139b6aae3 (patch)
tree705e0ae5f4af385ea1adefd53a5e15c392ad3ae9 /graphics
parente2c7ba06edc3755b18592c63f8b70c9ee2a2c12a (diff)
downloadfreebsd-ports-gnome-83d982230099c0d0fba8e4194bdc290139b6aae3.tar.gz
freebsd-ports-gnome-83d982230099c0d0fba8e4194bdc290139b6aae3.tar.zst
freebsd-ports-gnome-83d982230099c0d0fba8e4194bdc290139b6aae3.zip
graphics/mesa-dri: unbreak GCC build after r438198
configure: error: --enable-llvm is required when building r300 PR: 231329 Approved by: maintainer timeout (1 month)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mesa-dri/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/graphics/mesa-dri/Makefile b/graphics/mesa-dri/Makefile
index 84925638b351..c60841cda610 100644
--- a/graphics/mesa-dri/Makefile
+++ b/graphics/mesa-dri/Makefile
@@ -46,7 +46,11 @@ VULKAN_DRIVERS= #
.if ${ARCH} == amd64 || ${ARCH} == i386 \
|| ${ARCH} == powerpc || ${ARCH} == powerpc64
DRI_DRIVERS+= RADEON R200
-GALLIUM_DRIVERS+= R300 R600
+GALLIUM_DRIVERS+= R600
+. if "${MESA_LLVM_VER}" != "" && (${ARCH} == amd64 || ${ARCH} == i386)
+# https://cgit.freedesktop.org/mesa/mesa/commit/?id=58952675f6d4
+GALLIUM_DRIVERS+= R300
+. endif
. if "${MESA_LLVM_VER}" != "" # until PPC gets LLVM in base
GALLIUM_DRIVERS+= RADEONSI
VULKAN_DRIVERS+= RADEON