aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-27 04:32:15 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-27 04:32:15 +0800
commit85d651dc033b9c283cd40659794a6752db471d0e (patch)
tree236b5d0e753caf6862c5e9d1de6ea0aa0e32bff1 /graphics
parentc80acb7b47a1e63cc848709b4e358070397876d8 (diff)
downloadfreebsd-ports-gnome-85d651dc033b9c283cd40659794a6752db471d0e.tar.gz
freebsd-ports-gnome-85d651dc033b9c283cd40659794a6752db471d0e.tar.zst
freebsd-ports-gnome-85d651dc033b9c283cd40659794a6752db471d0e.zip
graphics/py-mayavi: Fix build (sphinx dependency was missing)
Also remove the unnecessary USE_PYTHON=concurrent. Reported by: fallout
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-mayavi/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/py-mayavi/Makefile b/graphics/py-mayavi/Makefile
index a1439eacf2d6..ddd26e99b130 100644
--- a/graphics/py-mayavi/Makefile
+++ b/graphics/py-mayavi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mayavi
DISTVERSION= 4.7.2
+PORTREVISION= 1
CATEGORIES= graphics science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -22,7 +23,8 @@ LICENSE_FILE_APACHE11= ${WRKSRC}/LICENSE_COLORBREWER.txt
BUILD_DEPENDS= vtk9>0:math/vtk9 \
${PYNUMPY} \
- ${PY_SPHINX}
+ ${PY_SPHINX} \
+ sphinx-build:textproc/py-sphinx@${PY_FLAVOR}
RUN_DEPENDS= vtk9>0:math/vtk9 \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}apptools>0:devel/py-apptools@${PY_FLAVOR} \
@@ -34,7 +36,7 @@ RUN_DEPENDS= vtk9>0:math/vtk9 \
${PYTHON_PKGNAMEPREFIX}traitsui>=6.0.0:graphics/py-traitsui@${PY_FLAVOR}
USES= python:3.6+ shebangfix
-USE_PYTHON= noflavors distutils concurrent autoplist # noflavors to force python to be of the same version as in vtk9, which always has default python version
+USE_PYTHON= noflavors distutils autoplist # noflavors to force python to be of the same version as in vtk9, which always has default python version
USE_WX= 3.0+
WX_COMPS= python:run