aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2018-02-04 23:10:06 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2018-02-04 23:10:06 +0800
commit87e7c1f489238cd21cf1879752b6921c1852ba63 (patch)
treebf073ce8eff31dbaf0fd623145911c4f2e6fb5d3 /graphics
parent8af8b94e04cbe07878998fe6765960fe8a217e9e (diff)
downloadfreebsd-ports-gnome-87e7c1f489238cd21cf1879752b6921c1852ba63.tar.gz
freebsd-ports-gnome-87e7c1f489238cd21cf1879752b6921c1852ba63.tar.zst
freebsd-ports-gnome-87e7c1f489238cd21cf1879752b6921c1852ba63.zip
graphics/libgphoto2: Convert custom REINPLACE_CMD to USES=pathfix
There is no functional difference with this change.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libgphoto2/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index 124754f26938..5eb67ec03ae9 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libltdl.so:devel/libltdl
-USES= gmake iconv libtool localbase pkgconfig tar:bzip2
+USES= gmake iconv libtool localbase pathfix pkgconfig tar:bzip2
USE_CSTD= gnu89
GNU_CONFIGURE= yes
CONFIGURE_ENV= LTDLINCL="-I${LOCALBASE}/include" \
@@ -25,6 +25,10 @@ CONFIGURE_ENV= LTDLINCL="-I${LOCALBASE}/include" \
udevscriptdir=${WRKDIR}
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
+PATHFIX_MAKEFILEIN= Makefile.in \
+ configure \
+ libgphoto2_port/Makefile.in \
+ libgphoto2_port/configure
PLIST_SUB= VERSION="${PORTVERSION}" VERSION_PORT=0.12.0
@@ -47,8 +51,7 @@ post-patch:
.for i in configure libgphoto2_port/configure
@${REINPLACE_CMD} -e \
'/FLAGS/s|-g|| ; \
- /grep -i linux/s|; fi ; then|; else false; fi ; then| ; \
- /pkgconfig/s|$${libdir}|$${prefix}/libdata|' \
+ /grep -i linux/s|; fi ; then|; else false; fi ; then|' \
${WRKSRC}/${i}
.endfor
@${REINPLACE_CMD} -e \