aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-03 02:39:59 +0800
committerantoine <antoine@FreeBSD.org>2014-02-03 02:39:59 +0800
commit8b1a1f6f061d669506c6709f3b188a80ca392050 (patch)
tree1a8ea1915f0a8589cf84c3dda85a3ec69591b049 /graphics
parentf46328ae7f5437cb5c146aea6235539cc0c2d6ba (diff)
downloadfreebsd-ports-gnome-8b1a1f6f061d669506c6709f3b188a80ca392050.tar.gz
freebsd-ports-gnome-8b1a1f6f061d669506c6709f3b188a80ca392050.tar.zst
freebsd-ports-gnome-8b1a1f6f061d669506c6709f3b188a80ca392050.zip
Stage support
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cthumb/Makefile22
-rw-r--r--graphics/cthumb/pkg-plist1
2 files changed, 11 insertions, 12 deletions
diff --git a/graphics/cthumb/Makefile b/graphics/cthumb/Makefile
index c0f688b1f570..c41f56d8974b 100644
--- a/graphics/cthumb/Makefile
+++ b/graphics/cthumb/Makefile
@@ -19,8 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/pnmscale:${PORTSDIR}/graphics/netpbm \
USES= perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-themedir=${DATADIR}
-
-MAN1= cthumb.1
+CONFIGURE_ENV= perl_path=${PERL}
PORTDOCS= ChangeLog INSTALL README TO-DO VERSION cthumbrc.sample
@@ -49,20 +48,19 @@ THEMES= blue-steel.theme \
tv-large.theme \
tv.theme
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/cthumb ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/cthumb.1 ${PREFIX}/man/man1
- ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/cthumb ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/cthumb.1 ${STAGEDIR}${PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DATADIR}
.for theme in ${THEMES}
- ${MKDIR} ${DATADIR}/${theme}
- ${INSTALL_DATA} ${WRKSRC}/themes/${theme}/* ${DATADIR}/${theme}
+ @${MKDIR} ${STAGEDIR}${DATADIR}/${theme}
+ ${INSTALL_DATA} ${WRKSRC}/themes/${theme}/* ${STAGEDIR}${DATADIR}/${theme}
.endfor
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/graphics/cthumb/pkg-plist b/graphics/cthumb/pkg-plist
index 9d17df99dbff..baef010fc283 100644
--- a/graphics/cthumb/pkg-plist
+++ b/graphics/cthumb/pkg-plist
@@ -1,4 +1,5 @@
bin/cthumb
+man/man1/cthumb.1.gz
%%DATADIR%%/blue-steel.theme/1.gif
%%DATADIR%%/blue-steel.theme/back.png
%%DATADIR%%/blue-steel.theme/bot.png