aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-12-30 03:59:33 +0800
committerdinoex <dinoex@FreeBSD.org>2003-12-30 03:59:33 +0800
commit8f91d26f5ca602dc2e8f5e3f0153d480fb7be82c (patch)
tree4cc89af7ba6c839095d4d72117f4933ea66d2f86 /graphics
parentcb670361f8dde1bddc49910e6ea1b18a2eb64d40 (diff)
downloadfreebsd-ports-gnome-8f91d26f5ca602dc2e8f5e3f0153d480fb7be82c.tar.gz
freebsd-ports-gnome-8f91d26f5ca602dc2e8f5e3f0153d480fb7be82c.tar.zst
freebsd-ports-gnome-8f91d26f5ca602dc2e8f5e3f0153d480fb7be82c.zip
- Fix argument handling in perl scripts
Submitted by: kstailey@yahoo.com
Diffstat (limited to 'graphics')
-rw-r--r--graphics/netpbm/Makefile2
-rw-r--r--graphics/netpbm/files/patch-editor-pnmquant45
2 files changed, 46 insertions, 1 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 9a6837a897e3..59347e0df6d8 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= netpbm
PORTVERSION= 10.19
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/netpbm/files/patch-editor-pnmquant b/graphics/netpbm/files/patch-editor-pnmquant
new file mode 100644
index 000000000000..df830ab671a1
--- /dev/null
+++ b/graphics/netpbm/files/patch-editor-pnmquant
@@ -0,0 +1,45 @@
+--- editor/pnmquant.DIST Mon Dec 29 08:11:52 2003
++++ editor/pnmquant Mon Dec 29 08:12:24 2003
+@@ -20,7 +20,7 @@
+
+ sub parseCommandLine(@) {
+
+- my @args = @_;
++ @ARGV = @_;
+
+ my ($opt_center, $opt_meancolor, $opt_meanpixel, $opt_floyd,
+ $opt_spreadbrightness, $opt_spreadluminosity, $opt_mapfile);
+@@ -34,18 +34,18 @@
+ "floyd|fs!" => \$opt_floyd,
+ );
+
+- if (@args > 2) {
++ if (@ARGV > 2) {
+ print(STDERR "This program takes at most 2 arguments. You specified ",
+- 0+@args, "\n");
++ 0+@ARGV, "\n");
+ exit(1);
+ }
+- if (@args < 1) {
++ if (@ARGV < 1) {
+ print(STDERR
+ "You must specify the number of colors as an argument.\n");
+ exit(1);
+ }
+ my $infile;
+- my $ncolors = $args[0];
++ my $ncolors = $ARGV[0];
+
+ if (!($ncolors =~ m{ ^[[:digit:]]+$ }x ) || $ncolors == 0) {
+ print(STDERR
+@@ -54,8 +54,8 @@
+ exit(1);
+ }
+
+- if (@args > 1) {
+- $infile = $args[1];
++ if (@ARGV > 1) {
++ $infile = $ARGV[1];
+ } else {
+ $infile = "-";
+ }