aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-10-20 04:20:21 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-10-20 04:20:21 +0800
commit8fc0dc2e29cddb4da02b52d940464e130102a6a0 (patch)
tree331415ead8efc692d2fd8c602102e3ab5088283b /graphics
parentcc93a168066a9b67c09ec56948a5e6d21d85f454 (diff)
downloadfreebsd-ports-gnome-8fc0dc2e29cddb4da02b52d940464e130102a6a0.tar.gz
freebsd-ports-gnome-8fc0dc2e29cddb4da02b52d940464e130102a6a0.tar.zst
freebsd-ports-gnome-8fc0dc2e29cddb4da02b52d940464e130102a6a0.zip
- Use USES=localbase
Diffstat (limited to 'graphics')
-rw-r--r--graphics/pngrewrite/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/graphics/pngrewrite/Makefile b/graphics/pngrewrite/Makefile
index a187675029a9..de2598da110d 100644
--- a/graphics/pngrewrite/Makefile
+++ b/graphics/pngrewrite/Makefile
@@ -15,16 +15,14 @@ LICENSE= ZLIB
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lm -lpng -lz
-USES= zip
+USES= localbase zip
NO_WRKSUBDIR= yes
PLIST_FILES= bin/pngrewrite
do-build:
- ${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/pngrewrite ${WRKSRC}/libpngrewrite.c ${WRKSRC}/pngrewrite.c
+ ${CC} ${CFLAGS} ${LDFLAGS} -lm -lpng -lz -o ${WRKSRC}/pngrewrite ${WRKSRC}/libpngrewrite.c ${WRKSRC}/pngrewrite.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pngrewrite ${STAGEDIR}${PREFIX}/bin/