aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-01-29 11:56:19 +0800
committerwen <wen@FreeBSD.org>2010-01-29 11:56:19 +0800
commit906b79f4152e43f22c5fd6d37abccde0dc73ae24 (patch)
treef5a254790a2b5c01ad02acebda5ea43305de4130 /graphics
parentbe69d36da63672956cd50c4b57a7e3081799240b (diff)
downloadfreebsd-ports-gnome-906b79f4152e43f22c5fd6d37abccde0dc73ae24.tar.gz
freebsd-ports-gnome-906b79f4152e43f22c5fd6d37abccde0dc73ae24.tar.zst
freebsd-ports-gnome-906b79f4152e43f22c5fd6d37abccde0dc73ae24.zip
- Add a option entry to support building with fastcgi
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mapserver/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index c5ab2eadabca..afa7b58bc4a5 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mapserver
PORTVERSION= 5.6.1
+PORTREVISION= 1
CATEGORIES= graphics www geography
MASTER_SITES= http://download.osgeo.org/mapserver/
@@ -35,6 +36,7 @@ OPTIONS= AGG "Support for AGG image rendering (req: FreeType)" off \
WMS "Support for web map service server and client" off \
WFS "Support for web feature service (req: GDAL)" off \
MAPSERV "Install mapserv cgi interface" on \
+ FASTCGI "Support FASTCGI" off \
DEBUG "Enable debugging output" off
.include <bsd.port.pre.mk>
@@ -120,6 +122,11 @@ PLIST_SUB+= WITH_MAPSERV=""
PLIST_SUB+= WITH_MAPSERV="@comment "
.endif
+.if defined(WITH_FASTCGI)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/cgi-fcgi:${PORTSDIR}/www/fcgi
+CONFIGURE_ARGS+= --with-fastcgi=${LOCALBASE}
+.endif
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif