aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-05-22 18:25:39 +0800
committerkwm <kwm@FreeBSD.org>2014-05-22 18:25:39 +0800
commit9077dd2c34546c8e077b40b36e36290c7d31a339 (patch)
tree29ea74731b4266d6d04b372cd068ad09f02ba7b6 /graphics
parente11b6975a325f951d494dc254301c2eba73327b2 (diff)
downloadfreebsd-ports-gnome-9077dd2c34546c8e077b40b36e36290c7d31a339.tar.gz
freebsd-ports-gnome-9077dd2c34546c8e077b40b36e36290c7d31a339.tar.zst
freebsd-ports-gnome-9077dd2c34546c8e077b40b36e36290c7d31a339.zip
Tweak OSVERSION check to also include newer 9.x versions, since gcc from
base is not good enough. For i386 depend on gcc form ports. This is due to a clang assertion [1], which has been reported in the clang bugtracker. Reported by: many [1]
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dri/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index a06ab7d9566c..69e161ee55a2 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -21,12 +21,13 @@ USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto
# We only care for 9.x and 8.x, not for old pre-clang default current.
# This is for 0b0000 binary which gcc 4.3+ understands and is in the i965 driver.
.if defined(WITH_NEW_XORG)
-. if ${OSVERSION} >= 901500 && ${OSVERSION} < 902502 \
- && (${ARCH} == i386 || ${ARCH} == amd64)
+. if (${OSVERSION} >= 901500 && ${OSVERSION} < 1000000) \
+ && ${ARCH} == amd64
CC=clang
CXX=clang++
CPP=clang-cpp
-. elif ${OSVERSION} < 901500
+# i386 triggers clang bug 19778. This happens with clang 3.4.1 and older.
+. elif ${OSVERSION} < 901500 || ${ARCH} == i386)
USE_GCC=yes
. endif
.endif