aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-28 23:32:33 +0800
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-28 23:32:33 +0800
commit916db42f99f75fad47efb2325b6fe73224537cfc (patch)
treee678e2dc094935fff8f8bc4a3b9a4e673f3afa56 /graphics
parent8ed21f8cee2a1c57481857624b8a3affd8679e13 (diff)
downloadfreebsd-ports-gnome-916db42f99f75fad47efb2325b6fe73224537cfc.tar.gz
freebsd-ports-gnome-916db42f99f75fad47efb2325b6fe73224537cfc.tar.zst
freebsd-ports-gnome-916db42f99f75fad47efb2325b6fe73224537cfc.zip
Add port graphics/libgfx:
The purpose of this library is to simplify the creation of computer graphics software. Specifically, it is targeted towards cross-platform development using the OpenGL rendering API and the FLTK interface toolkit. It attempts to provide facilities which are useful in the majority of graphics programs. This release introduces some (relatively small) incompatible changes with 1.0.x versions of the library. Details on changes can be found below. WWW: http://graphics.cs.uiuc.edu/~garland/software/libgfx.html
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libgfx/Makefile36
-rw-r--r--graphics/libgfx/distinfo3
-rw-r--r--graphics/libgfx/pkg-descr9
-rw-r--r--graphics/libgfx/pkg-plist35
5 files changed, 84 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index a614393e0092..ad076eafa773 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -330,6 +330,7 @@
SUBDIR += libfpx
SUBDIR += libgdgeda
SUBDIR += libgeotiff
+ SUBDIR += libgfx
SUBDIR += libggi
SUBDIR += libggigcp
SUBDIR += libggimisc
diff --git a/graphics/libgfx/Makefile b/graphics/libgfx/Makefile
new file mode 100644
index 000000000000..54675ed7fa4a
--- /dev/null
+++ b/graphics/libgfx/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: libgfx
+# Date created: 28 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgfx
+DISTVERSION= 1.1.0
+CATEGORIES= graphics
+MASTER_SITES= http://graphics.cs.uiuc.edu/~garland/dist/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Generates three-dimensional coherent noise
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgzstream.a:${PORTSDIR}/devel/gzstream
+
+USE_GL= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --enable-gzstream --with-libtiff-lzw --with-x
+CFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+BUILD_WRKSRC= ${WRKSRC}/src
+ALL_TARGET= libgfx.a
+
+do-install:
+ @${CP} -R ${WRKSRC}/include/gfx ${PREFIX}/include/
+ @${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.a ${PREFIX}/lib/
+
+.include <bsd.port.mk>
diff --git a/graphics/libgfx/distinfo b/graphics/libgfx/distinfo
new file mode 100644
index 000000000000..61262ebf7032
--- /dev/null
+++ b/graphics/libgfx/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgfx-1.1.0.tar.gz) = 7533ef6e5a8da8b7d03eca4c64787983
+SHA256 (libgfx-1.1.0.tar.gz) = 2bd53940c068c40125a8cfebcbd519c10c8630f8bdf4ebe9f57d328c74ad0284
+SIZE (libgfx-1.1.0.tar.gz) = 145470
diff --git a/graphics/libgfx/pkg-descr b/graphics/libgfx/pkg-descr
new file mode 100644
index 000000000000..1fa21a9aff44
--- /dev/null
+++ b/graphics/libgfx/pkg-descr
@@ -0,0 +1,9 @@
+The purpose of this library is to simplify the creation of computer graphics
+software. Specifically, it is targeted towards cross-platform development
+using the OpenGL rendering API and the FLTK interface toolkit. It attempts
+to provide facilities which are useful in the majority of graphics programs.
+
+This release introduces some (relatively small) incompatible changes with
+1.0.x versions of the library. Details on changes can be found below.
+
+WWW: http://graphics.cs.uiuc.edu/~garland/software/libgfx.html
diff --git a/graphics/libgfx/pkg-plist b/graphics/libgfx/pkg-plist
new file mode 100644
index 000000000000..1c7e9764bdf1
--- /dev/null
+++ b/graphics/libgfx/pkg-plist
@@ -0,0 +1,35 @@
+include/gfx/arcball.h
+include/gfx/array.h
+include/gfx/baseball.h
+include/gfx/color.h
+include/gfx/config-osx.h
+include/gfx/config-vc.h
+include/gfx/config.h
+include/gfx/config.h.in
+include/gfx/geom3d.h
+include/gfx/geom4d.h
+include/gfx/gfx.h
+include/gfx/gl.h
+include/gfx/glext.h
+include/gfx/gltools.h
+include/gfx/gui.h
+include/gfx/intvec.h
+include/gfx/mat2.h
+include/gfx/mat3.h
+include/gfx/mat4.h
+include/gfx/quat.h
+include/gfx/raster.h
+include/gfx/script.h
+include/gfx/symmat2.h
+include/gfx/symmat3.h
+include/gfx/symmat4.h
+include/gfx/trackball.h
+include/gfx/vec2.h
+include/gfx/vec3.h
+include/gfx/vec4.h
+include/gfx/win/gui-mfc.h
+include/gfx/win/mfc.h
+include/gfx/win/wintools.h
+lib/libgfx.a
+@dirrm include/gfx/win
+@dirrm include/gfx