aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2019-06-07 04:02:19 +0800
committerantoine <antoine@FreeBSD.org>2019-06-07 04:02:19 +0800
commit9968b226258521a814477700f47c8a289708b496 (patch)
tree10b2241e2cb2c3c08f5a688f337ff6b6342b24a5 /graphics
parent464773dc45155efd4e85953a6b35a0692a6d1723 (diff)
downloadfreebsd-ports-gnome-9968b226258521a814477700f47c8a289708b496.tar.gz
freebsd-ports-gnome-9968b226258521a814477700f47c8a289708b496.tar.zst
freebsd-ports-gnome-9968b226258521a814477700f47c8a289708b496.zip
Fix tiff2ps error regarding "Inconsistent value of es" by allowing es to be zero.
PR: 238372
Diffstat (limited to 'graphics')
-rw-r--r--graphics/tiff/Makefile1
-rw-r--r--graphics/tiff/files/patch-tools_tiff2ps.c16
2 files changed, 17 insertions, 0 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
index 3ace6c0cf527..fda113033fb3 100644
--- a/graphics/tiff/Makefile
+++ b/graphics/tiff/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tiff
PORTVERSION= 4.0.10
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= https://download.osgeo.org/libtiff/
diff --git a/graphics/tiff/files/patch-tools_tiff2ps.c b/graphics/tiff/files/patch-tools_tiff2ps.c
new file mode 100644
index 000000000000..1a3645d65586
--- /dev/null
+++ b/graphics/tiff/files/patch-tools_tiff2ps.c
@@ -0,0 +1,16 @@
+Fix tiff2ps error regarding "Inconsistent value of es" by allowing es to be zero.
+
+--- tools/tiff2ps.c.orig 2018-11-03 19:25:46 UTC
++++ tools/tiff2ps.c
+@@ -2444,9 +2444,9 @@ PSDataColorContig(FILE* fd, TIFF* tif, u
+ unsigned char *cp, c;
+
+ (void) w;
+- if( es <= 0 )
++ if( es < 0 )
+ {
+- TIFFError(filename, "Inconsistent value of es: %d", es);
++ TIFFError(filename, "Inconsistent value of es: %d (samplesperpixel=%u, nc=%d)", es, samplesperpixel, nc);
+ return;
+ }
+ tf_buf = (unsigned char *) _TIFFmalloc(tf_bytesperrow);