aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2016-11-14 07:53:07 +0800
committerdinoex <dinoex@FreeBSD.org>2016-11-14 07:53:07 +0800
commit9b57a899ece213e4c14c0882dd1d03cec1204d79 (patch)
tree1c1d8d1c0555b777098062400d82745ae1cf7c06 /graphics
parentf4c93e61f38148901bda0aa7a3094aaa4437df05 (diff)
downloadfreebsd-ports-gnome-9b57a899ece213e4c14c0882dd1d03cec1204d79.tar.gz
freebsd-ports-gnome-9b57a899ece213e4c14c0882dd1d03cec1204d79.tar.zst
freebsd-ports-gnome-9b57a899ece213e4c14c0882dd1d03cec1204d79.zip
- fix build on aarch64
PR: 213864 Submitted by: Andrew Turner
Diffstat (limited to 'graphics')
-rw-r--r--graphics/graphviz/Makefile4
-rw-r--r--graphics/graphviz/files/patch-lib-vmalloc-vmhdr.h13
2 files changed, 15 insertions, 2 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 4e4f9c175ddc..1b40a2c79482 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -3,7 +3,7 @@
PORTNAME= graphviz
PORTVERSION= 2.38.0
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= graphics tk
MASTER_SITES= http://www.graphviz.org/pub/graphviz/ARCHIVE/
@@ -17,7 +17,7 @@ LIB_DEPENDS= libltdl.so:devel/libltdl \
libexpat.so:textproc/expat2 \
libgd.so:${GD_PORT}
-ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS= aarch64 amd64 i386
USES= bison cpe gmake jpeg libtool:keepla pkgconfig pathfix shebangfix
GNU_CONFIGURE= yes
diff --git a/graphics/graphviz/files/patch-lib-vmalloc-vmhdr.h b/graphics/graphviz/files/patch-lib-vmalloc-vmhdr.h
new file mode 100644
index 000000000000..e5cffa97b1ac
--- /dev/null
+++ b/graphics/graphviz/files/patch-lib-vmalloc-vmhdr.h
@@ -0,0 +1,13 @@
+--- lib/vmalloc/vmhdr.h.orig 2016-11-07 02:32:54.935418000 +0000
++++ lib/vmalloc/vmhdr.h 2016-11-07 02:38:16.506108000 +0000
+@@ -20,6 +20,10 @@
+ #ifndef _BLD_vmalloc
+ #define _BLD_vmalloc 1
+ #endif
++#if defined(__FreeBSD__) && defined(__aarch64__)
++/* No sbrk on FreeBSD/AArch64 */
++#define _std_malloc 1
++#endif
+ #ifdef WIN32
+ #include <io.h>
+ #endif