aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-20 10:32:42 +0800
committerwill <will@FreeBSD.org>2001-03-20 10:32:42 +0800
commita2a31d2d2dbe88801a6fa031a2ec709fb0d339a0 (patch)
tree8a90f03b2b146e72aa56e554f89198fe7744760c /graphics
parent5b03dcdf81501e86ccfc0c1e338b80be4c228ea4 (diff)
downloadfreebsd-ports-gnome-a2a31d2d2dbe88801a6fa031a2ec709fb0d339a0.tar.gz
freebsd-ports-gnome-a2a31d2d2dbe88801a6fa031a2ec709fb0d339a0.tar.zst
freebsd-ports-gnome-a2a31d2d2dbe88801a6fa031a2ec709fb0d339a0.zip
Add xmms-avi 1.2.2, an avifile based .avi and .asf file playback
plugin for XMMS. Very cool! PR: 24939 Submitted by: Roman Shterenzon <roman@xpert.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/xmms-avi/Makefile38
-rw-r--r--graphics/xmms-avi/distinfo1
-rw-r--r--graphics/xmms-avi/files/patch-configure12
-rw-r--r--graphics/xmms-avi/pkg-comment1
-rw-r--r--graphics/xmms-avi/pkg-descr5
-rw-r--r--graphics/xmms-avi/pkg-plist1
7 files changed, 59 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b7d789f2bbe5..1865bff7bcab 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -243,6 +243,7 @@
SUBDIR += xmagv
SUBDIR += xmandel
SUBDIR += xmfract
+ SUBDIR += xmms-avi
SUBDIR += xmms-gforce
SUBDIR += xmorph
SUBDIR += xmountains
diff --git a/graphics/xmms-avi/Makefile b/graphics/xmms-avi/Makefile
new file mode 100644
index 000000000000..ebacbd78c4bc
--- /dev/null
+++ b/graphics/xmms-avi/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: xmms-avi
+# Date created: Feb 6 2000
+# Whom: Roman Shterenzon <roman@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-avi
+PORTVERSION= 1.2.2
+CATEGORIES= graphics
+MASTER_SITES= http://www.xmms.org/files/plugins/avi-xmms/ \
+ ftp://ftp.sunet.se/pub/multimedia/xmms/plugins/avi-xmms/ \
+ ftp://ftp.fu-berlin.de/unix/sound/xmms/plugins/avi-xmms/
+DISTNAME= avi-xmms-${PORTVERSION}
+
+MAINTAINER= roman@xpert.com
+
+BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
+LIB_DEPENDS= aviplay.0:${PORTSDIR}/graphics/avifile
+RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+pre-patch:
+ @${PERL} -pi.orig -e "s|SDL/SDL.h|SDL11/SDL.h|g" ${WRKSRC}/src/ctrackbar.cpp
+ @${PERL} -pi.orig -e "s|lc_r|pthread|g" ${WRKSRC}/configure
+
+# This is to avoid libtool running ldconfig -m ${X11BASE}/lib/xmms/Input
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/libavixmms.so ${PREFIX}/lib/xmms/Input
+
+.include <bsd.port.mk>
diff --git a/graphics/xmms-avi/distinfo b/graphics/xmms-avi/distinfo
new file mode 100644
index 000000000000..8d2256e3c845
--- /dev/null
+++ b/graphics/xmms-avi/distinfo
@@ -0,0 +1 @@
+MD5 (avi-xmms-1.2.2.tar.gz) = 0532dce534cf6f7ba1d1563547128659
diff --git a/graphics/xmms-avi/files/patch-configure b/graphics/xmms-avi/files/patch-configure
new file mode 100644
index 000000000000..722cdcc20d60
--- /dev/null
+++ b/graphics/xmms-avi/files/patch-configure
@@ -0,0 +1,12 @@
+--- configure.orig Wed Feb 7 22:07:08 2001
++++ configure Wed Feb 7 22:08:06 2001
+@@ -2192,7 +2192,8 @@
+ no_sdl=yes
+ else
+ SDL_CFLAGS=`$SDL_CONFIG $sdlconf_args --cflags`
+- SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs`
++# Having Xxf86vm and friends makes libtool unhappy and unable to create .so
++ SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs | sed 's/-lXxf86vm -lXxf86dga -lXv//'`
+
+ sdl_major_version=`$SDL_CONFIG $sdl_args --version | \
+ sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
diff --git a/graphics/xmms-avi/pkg-comment b/graphics/xmms-avi/pkg-comment
new file mode 100644
index 000000000000..caa45901bf15
--- /dev/null
+++ b/graphics/xmms-avi/pkg-comment
@@ -0,0 +1 @@
+An avifile based .avi and .asf file playback plugin for XMMS
diff --git a/graphics/xmms-avi/pkg-descr b/graphics/xmms-avi/pkg-descr
new file mode 100644
index 000000000000..9cd998442dde
--- /dev/null
+++ b/graphics/xmms-avi/pkg-descr
@@ -0,0 +1,5 @@
+An avifile and SDL based .avi and .asf file playback plugin for XMMS.
+
+WWW: http://www.xmms.org/
+
+Roman Shterenzon <roman@xpert.com>
diff --git a/graphics/xmms-avi/pkg-plist b/graphics/xmms-avi/pkg-plist
new file mode 100644
index 000000000000..24cad51e2343
--- /dev/null
+++ b/graphics/xmms-avi/pkg-plist
@@ -0,0 +1 @@
+lib/xmms/Input/libavixmms.so