aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-12-22 09:44:15 +0800
committerlinimon <linimon@FreeBSD.org>2018-12-22 09:44:15 +0800
commita5904b574edc5ef3b24ab6c355c35e527b2b45f6 (patch)
tree4deea83e314191b44f9cf13d06f8374494a97f8f /graphics
parent270bfee03a0bad0699ea95bf3338da0b0c18391c (diff)
downloadfreebsd-ports-gnome-a5904b574edc5ef3b24ab6c355c35e527b2b45f6.tar.gz
freebsd-ports-gnome-a5904b574edc5ef3b24ab6c355c35e527b2b45f6.tar.zst
freebsd-ports-gnome-a5904b574edc5ef3b24ab6c355c35e527b2b45f6.zip
This port needs USES=compiler:c++11-lang to build on GCC-based
architectures. Additionally, our CXXFLAGS conflict with GCC. Set them only on Clang- based architectures. -stdlib=libc++ isn't needed anymore, it's used by default. While here, also set USES=gnome. PR: 234190 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gimmage/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/gimmage/Makefile b/graphics/gimmage/Makefile
index e08fe69d75f8..ac9789825b53 100644
--- a/graphics/gimmage/Makefile
+++ b/graphics/gimmage/Makefile
@@ -13,13 +13,11 @@ COMMENT= Simple image viewer
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to configure: C++ compiler cannot create executables
-
LIB_DEPENDS= libcurl.so:ftp/curl \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= compiler:c++11-lang desktop-file-utils gettext pkgconfig
+USES= compiler:c++11-lang desktop-file-utils gettext gnome pkgconfig
USE_GNOME= gtkmm24 gdkpixbuf2
GNU_CONFIGURE= yes
USE_CXXSTD= c++11
@@ -28,9 +26,12 @@ OPTIONS_DEFINE= NLS
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= gettext
-CXXFLAGS+= -stdlib=libc++ -Wc++11-extensions -Wc++11-long-long \
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+
+.if !exists(/usr/lib/libstdc++.so)
+CXXFLAGS+= -Wc++11-extensions -Wc++11-long-long \
-Wunused-command-line-argument -Wreturn-type \
-Wwritable-strings -Wlogical-op-parentheses
-CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+.endif
.include <bsd.port.mk>