aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-09-11 19:18:34 +0800
committermiwi <miwi@FreeBSD.org>2010-09-11 19:18:34 +0800
commita8ce338c190d032bc7f597e49d0da9efe23e0a3e (patch)
tree5d65738b8b1c8867129bdf0f9a036d707f0bdeb7 /graphics
parent1ec2c0c0967a895ff11392a7915869c78e1e2bcc (diff)
downloadfreebsd-ports-gnome-a8ce338c190d032bc7f597e49d0da9efe23e0a3e.tar.gz
freebsd-ports-gnome-a8ce338c190d032bc7f597e49d0da9efe23e0a3e.tar.zst
freebsd-ports-gnome-a8ce338c190d032bc7f597e49d0da9efe23e0a3e.zip
- Add missing math/fftw3 to LIB_DEPENDS
- Add OPTION for print/pdflib support - Fix disabling WITH_LAME to effect properly PR: 148559 Submitted by: Ports Fury Approved by: maintainer
Diffstat (limited to 'graphics')
-rw-r--r--graphics/swftools/Makefile20
-rw-r--r--graphics/swftools/pkg-plist1
2 files changed, 18 insertions, 3 deletions
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index 3674e5933177..71e1a811ec8f 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -8,6 +8,7 @@
PORTNAME= swftools
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.swftools.org/ \
http://www.c-s.li/ports/
@@ -18,18 +19,21 @@ COMMENT= SWF manipulation and generation utilities
LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
jpeg.11:${PORTSDIR}/graphics/jpeg \
ungif.5:${PORTSDIR}/graphics/libungif \
+ fftw3.5:${PORTSDIR}/math/fftw3 \
freetype.9:${PORTSDIR}/print/freetype2 \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
LICENSE= GPLv2
-OPTIONS= LAME "LAME MP3 audio encoder support" off
+OPTIONS= LAME "LAME MP3 audio encoder support" off \
+ PDF "PDFlib support" off
USE_GNOME= pkgconfig
USE_GL= glut
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ ac_cv_lib_zzip_zzip_file_open=no
MAKE_JOBS_SAFE= yes
@@ -45,7 +49,17 @@ LDFLAGS= -L${LOCALBASE}/lib
.if defined(WITH_LAME)
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
.else
-CONFIGURE_ARGS+= --disable-lame
+#CONFIGURE_ARGS+= --disable-lame
+CONFIGURE_ENV+= ac_cv_lib_mp3lame_lame_init=no
+.endif
+
+.if defined(WITH_PDF)
+LIB_DEPENDS+= pdf.8:${PORTSDIR}/print/pdflib
+PLIST_SUB+= PDF=""
+MAN1+= pdf2pdf.1
+.else
+CONFIGURE_ENV+= ac_cv_lib_pdf_PDF_open_file=no
+PLIST_SUB+= PDF="@comment "
.endif
post-patch:
diff --git a/graphics/swftools/pkg-plist b/graphics/swftools/pkg-plist
index 1ce058e8b940..b600c1bcd11c 100644
--- a/graphics/swftools/pkg-plist
+++ b/graphics/swftools/pkg-plist
@@ -2,6 +2,7 @@ bin/as3compile
bin/font2swf
bin/gif2swf
bin/jpeg2swf
+%%PDF%%bin/pdf2pdf
bin/pdf2swf
bin/png2swf
bin/swfbbox