aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-02-16 08:56:04 +0800
committerade <ade@FreeBSD.org>2000-02-16 08:56:04 +0800
commita9cff7a5223b8fd77c69d156eb6c0fee49857048 (patch)
tree11114700b4914bd3f900e32a798b6a5054afa496 /graphics
parentbc8072485d87ce0f44e456365aebe80c314082e9 (diff)
downloadfreebsd-ports-gnome-a9cff7a5223b8fd77c69d156eb6c0fee49857048.tar.gz
freebsd-ports-gnome-a9cff7a5223b8fd77c69d156eb6c0fee49857048.tar.zst
freebsd-ports-gnome-a9cff7a5223b8fd77c69d156eb6c0fee49857048.zip
Use libungif (support for it was already present in the
configure script). GNOME packages should build again now.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/imlib/Makefile4
-rw-r--r--graphics/imlib2-tmp/Makefile4
-rw-r--r--graphics/imlib2/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/graphics/imlib/Makefile b/graphics/imlib/Makefile
index 1478494629fa..210b8bb56892 100644
--- a/graphics/imlib/Makefile
+++ b/graphics/imlib/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= vanilla@FreeBSD.org
LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
- gif.5:${PORTSDIR}/graphics/giflib \
+ ungif.5:${PORTSDIR}/graphics/libungif \
gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/giflib" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/graphics/imlib2-tmp/Makefile b/graphics/imlib2-tmp/Makefile
index 1478494629fa..210b8bb56892 100644
--- a/graphics/imlib2-tmp/Makefile
+++ b/graphics/imlib2-tmp/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= vanilla@FreeBSD.org
LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
- gif.5:${PORTSDIR}/graphics/giflib \
+ ungif.5:${PORTSDIR}/graphics/libungif \
gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/giflib" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index 1478494629fa..210b8bb56892 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= vanilla@FreeBSD.org
LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
- gif.5:${PORTSDIR}/graphics/giflib \
+ ungif.5:${PORTSDIR}/graphics/libungif \
gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/giflib" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"