aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-09-25 15:29:25 +0800
committerlinimon <linimon@FreeBSD.org>2018-09-25 15:29:25 +0800
commitae8146aa21f2c06d1c87bfa3fa60c6a09f8861c8 (patch)
tree262a5db58bff73f86c94d292d6eafdc8e48838a9 /graphics
parentd495fbb251be86e97774ce324868aaa2b4734675 (diff)
downloadfreebsd-ports-gnome-ae8146aa21f2c06d1c87bfa3fa60c6a09f8861c8.tar.gz
freebsd-ports-gnome-ae8146aa21f2c06d1c87bfa3fa60c6a09f8861c8.tar.zst
freebsd-ports-gnome-ae8146aa21f2c06d1c87bfa3fa60c6a09f8861c8.zip
These ports now build on powerpc64.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/inkscape/Makefile4
-rw-r--r--graphics/mapnik/Makefile5
2 files changed, 3 insertions, 6 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index b0b2816bca25..99ab35dafa9f 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -16,8 +16,6 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/GPL2.txt
LICENSE_FILE_GPLv3= ${WRKSRC}/GPL3.txt
LICENSE_FILE_LGPL21= ${WRKSRC}/LGPL2.1.txt
-BROKEN_powerpc64= fails to build: lib/libinkscape_base.so: undefined reference to Magick::Image::read(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)
-
BUILD_DEPENDS= ${LOCALBASE}/include/boost/concept_check.hpp:devel/boost-libs
LIB_DEPENDS= libpopt.so:devel/popt \
libgc.so:devel/boehm-gc \
@@ -32,10 +30,10 @@ LIB_DEPENDS= libpopt.so:devel/popt \
libpng.so:graphics/png \
libMagick++-6.so:graphics/ImageMagick
-USE_GNOME= gtkmm24 libxml2 libxslt
USES= compiler:c++11-lib cmake cpe desktop-file-utils gnome \
iconv:wchar_t jpeg pathfix pkgconfig python:2.7,build \
shebangfix tar:bzip2
+USE_GNOME= gtkmm24 libxml2 libxslt
USE_XORG= x11
INSTALLS_ICONS= yes
CMAKE_ARGS+= -DWITH_GNOME_VFS:BOOL=NO
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index b51e278793f2..a5127d1839c0 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -18,14 +18,13 @@ COMMENT= Free Toolkit For Developing Mapping Applications
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc= fails to install: runs out of virtual memory
+
LIB_DEPENDS= libicuuc.so:devel/icu \
libboost_system.so:devel/boost-libs \
libfreetype.so:print/freetype2 \
libharfbuzz.so:print/harfbuzz
-BROKEN_powerpc= fails to install: runs out of virtual memory
-BROKEN_powerpc64= fails to link: libmapnik.so: undefined reference to boost::match_results
-
USES= compiler:c++11-lib pkgconfig python scons tar:bzip2
USE_GNOME= libxml2
USE_LDCONFIG= yes