aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-05 15:53:27 +0800
committerpav <pav@FreeBSD.org>2006-05-05 15:53:27 +0800
commitaf51700c7c9881ec588222a005d8f602c1985300 (patch)
tree638d7dca883ce8f42250d77bba52be1f3e96215a /graphics
parent1e0c416b5f710d45df2fae301d51ed3f3990df7c (diff)
downloadfreebsd-ports-gnome-af51700c7c9881ec588222a005d8f602c1985300.tar.gz
freebsd-ports-gnome-af51700c7c9881ec588222a005d8f602c1985300.tar.zst
freebsd-ports-gnome-af51700c7c9881ec588222a005d8f602c1985300.zip
The port uses -msse compiler option, which I've disabled by ports/95552 to make
it compile under amd64. That led to the port not compiling anywhere at all, as sse dependancy is hardcoded. So: - Don't remove -msse from compiler flags - Introduce ONLY_FOR_ARCHS=i386 PR: ports/95872 Submitted by: Dmitry Marakasov <amdmi3@mail.ru> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sharpconstruct/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/sharpconstruct/Makefile b/graphics/sharpconstruct/Makefile
index 74ae7c49106c..b19719f7b8d8 100644
--- a/graphics/sharpconstruct/Makefile
+++ b/graphics/sharpconstruct/Makefile
@@ -26,6 +26,8 @@ USE_GCC= 3.4+
MAN1= sharpconstruct.1
+ONLY_FOR_ARCHS= i386
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
@@ -41,6 +43,5 @@ post-patch:
@${REINPLACE_CMD} -e 's|memalign(b,c)|malloc(c)|' ${WRKSRC}/include/Align.hh
@${FIND} ${WRKSRC} -name Makefile.in -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e '/^DEFS / s|$$| -DDATADIR=\\"${DATADIR}\\"|'
- @${REINPLACE_CMD} -e 's|-msse||' ${WRKSRC}/src/Makefile.in
.include <bsd.port.post.mk>