aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-01-19 16:56:58 +0800
committermiwi <miwi@FreeBSD.org>2014-01-19 16:56:58 +0800
commitafd6d20d55826a9ed2544f97d48e5ffa008f5f58 (patch)
treeaaa1a595f7b3e43770712b45efa4d6ffb55fc1cc /graphics
parent4de269c57df2b9227ce4a97a7fc7ba4f5ab7d073 (diff)
downloadfreebsd-ports-gnome-afd6d20d55826a9ed2544f97d48e5ffa008f5f58.tar.gz
freebsd-ports-gnome-afd6d20d55826a9ed2544f97d48e5ffa008f5f58.tar.zst
freebsd-ports-gnome-afd6d20d55826a9ed2544f97d48e5ffa008f5f58.zip
- Fix build with clang
PR: 185337
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xmms-fishmatic/Makefile36
-rw-r--r--graphics/xmms-fishmatic/files/patch-configure22
-rw-r--r--graphics/xmms-fishmatic/files/patch-ltmain.sh27
3 files changed, 21 insertions, 64 deletions
diff --git a/graphics/xmms-fishmatic/Makefile b/graphics/xmms-fishmatic/Makefile
index 633c6bd29d18..d7cc66ded280 100644
--- a/graphics/xmms-fishmatic/Makefile
+++ b/graphics/xmms-fishmatic/Makefile
@@ -11,27 +11,33 @@ DISTNAME= fishmatic
MAINTAINER= ports@FreeBSD.org
COMMENT= XMMS non-static OpenGL stereogram visualization plugin
-BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
-RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+BUILD_DEPENDS= xmms>0:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms>0:${PORTSDIR}/multimedia/xmms
-PLIST_FILES= lib/xmms/Visualization/libfishmatic.so
-USE_GNOME= gtk12
USES= gmake pkgconfig
-GNU_CONFIGURE= yes
-USE_GL= glut
USE_XORG= xext
-USE_LDCONFIG= yes
+USE_GNOME= gtk12
+USE_GL= glut
+USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= LIBS="-lGL -lXext ${LIBS}"
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= lib/xmms/Visualization/libfishmatic.so
-NO_STAGE= yes
post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|"-lpthread|"-pthread|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|-O2|| ; \
+ s|@PNG_LIBS@||' ${WRKSRC}/Makefile.in
+
+pre-configure:
@${RM} -f ${WRKSRC}/config.cache
- @${REINPLACE_CMD} -e 's|-O2||; \
- s|-lpthreads|${PTHREAD_LIBS:S/"//g}|g' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/ltconfig
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/xmms/Visualization
+ (cd ${WRKSRC}/.libs && ${INSTALL_LIB} libfishmatic.so \
+ ${STAGEDIR}${PREFIX}/lib/xmms/Visualization)
.include <bsd.port.mk>
diff --git a/graphics/xmms-fishmatic/files/patch-configure b/graphics/xmms-fishmatic/files/patch-configure
deleted file mode 100644
index 346c63b28577..000000000000
--- a/graphics/xmms-fishmatic/files/patch-configure
+++ /dev/null
@@ -1,22 +0,0 @@
-$FreeBSD$
-
---- configure.orig Sun Aug 12 19:11:07 2001
-+++ configure Thu Dec 27 00:05:42 2001
-@@ -3243,7 +3243,7 @@
- #include "confdefs.h"
- #include <GL/gl.h>
- EOF
--ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-+ac_try="$ac_cpp $CFLAGS conftest.$ac_ext >/dev/null 2>conftest.out"
- { (eval echo configure:3248: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
- ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
- if test -z "$ac_err"; then
-@@ -3364,7 +3364,7 @@
- #include "confdefs.h"
- #include <GL/glx.h>
- EOF
--ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-+ac_try="$ac_cpp $CFLAGS conftest.$ac_ext >/dev/null 2>conftest.out"
- { (eval echo configure:3369: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
- ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
- if test -z "$ac_err"; then
diff --git a/graphics/xmms-fishmatic/files/patch-ltmain.sh b/graphics/xmms-fishmatic/files/patch-ltmain.sh
deleted file mode 100644
index 938ad55d97f6..000000000000
--- a/graphics/xmms-fishmatic/files/patch-ltmain.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-$FreeBSD$
-
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"