aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorhoek <hoek@FreeBSD.org>1998-08-22 05:40:02 +0800
committerhoek <hoek@FreeBSD.org>1998-08-22 05:40:02 +0800
commitb125264952920dad20bc92d895d55cb6cee866b2 (patch)
tree5eacd4257127bc5fd1849314634862a65a91cc5e /graphics
parent79d7c5b2a3bc46f060763fcf5e65c0acc3cf33b7 (diff)
downloadfreebsd-ports-gnome-b125264952920dad20bc92d895d55cb6cee866b2.tar.gz
freebsd-ports-gnome-b125264952920dad20bc92d895d55cb6cee866b2.tar.zst
freebsd-ports-gnome-b125264952920dad20bc92d895d55cb6cee866b2.zip
Respect prefix. Make this build on -current by changing
"cc /usr/lib/libz.a" to "cc -lz".
Diffstat (limited to 'graphics')
-rw-r--r--graphics/hdf/Makefile6
-rw-r--r--graphics/hdf/scripts/post-patch4
-rw-r--r--graphics/hdf5/Makefile6
-rw-r--r--graphics/hdf5/scripts/post-patch4
4 files changed, 14 insertions, 6 deletions
diff --git a/graphics/hdf/Makefile b/graphics/hdf/Makefile
index a27f3eca57f5..220d5de2ce5d 100644
--- a/graphics/hdf/Makefile
+++ b/graphics/hdf/Makefile
@@ -3,7 +3,7 @@
# Date created: 17 November 1996
# Whom: mi
#
-# $Id: Makefile,v 1.3 1998/04/08 12:53:43 tg Exp $
+# $Id: Makefile,v 1.4 1998/06/04 23:18:46 steve Exp $
#
DISTNAME= HDF4.1r2
@@ -18,12 +18,16 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
FC?= f77 # Can also be g77 for the newer one
MAKE_FLAGS= CC="$(CC)" FC="${FC}" -f
+MAKE_ENV= pwrkdir=${WRKDIR}
+#"wrkdir" doesn't work for some reason in the above
# This will create dummy Makefiles and some links in the jpeg and libz
# subdirectories. This way, we do not need to hunt all the dependencies
# out. Shame on the lib's developers, though, this can not be done through
# `configure'. -mi
pre-build:
+ ${AR} -r ${WRKDIR}/libz.a /dev/null
+ ${RANLIB} ${WRKDIR}/libz.a
test -d ${WRKSRC}/hdf/jpeg.came-with-HDF || \
${MV} -f ${WRKSRC}/hdf/jpeg ${WRKSRC}/hdf/jpeg.came-with-HDF
-${MKDIR} ${WRKSRC}/hdf/jpeg
diff --git a/graphics/hdf/scripts/post-patch b/graphics/hdf/scripts/post-patch
index 1afaf52ab9ef..0922398e3d40 100644
--- a/graphics/hdf/scripts/post-patch
+++ b/graphics/hdf/scripts/post-patch
@@ -39,7 +39,7 @@ patch -p << END_OF_PATCH
-ZLIBINC=\$(srcdir)/../zlib
-ZLIBLIB=\$(srcdir)/../zlib
+ZLIBINC=/usr/include
-+ZLIBLIB=/usr/lib
++ZLIBLIB=-lz \$(pwrkdir)
END_OF_PATCH
done
@@ -51,7 +51,7 @@ patch -p << END_OF_PATCH
@@ -72,2 +72,2 @@
-ZLIBLIB=\$(srcdir)/../zlib
-ZLIBINC=\$(srcdir)/../zlib
-+ZLIBLIB=/usr/lib
++ZLIBLIB=-lz \$(pwrkdir)
+ZLIBINC=/usr/include
END_OF_PATCH
done
diff --git a/graphics/hdf5/Makefile b/graphics/hdf5/Makefile
index a27f3eca57f5..220d5de2ce5d 100644
--- a/graphics/hdf5/Makefile
+++ b/graphics/hdf5/Makefile
@@ -3,7 +3,7 @@
# Date created: 17 November 1996
# Whom: mi
#
-# $Id: Makefile,v 1.3 1998/04/08 12:53:43 tg Exp $
+# $Id: Makefile,v 1.4 1998/06/04 23:18:46 steve Exp $
#
DISTNAME= HDF4.1r2
@@ -18,12 +18,16 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
FC?= f77 # Can also be g77 for the newer one
MAKE_FLAGS= CC="$(CC)" FC="${FC}" -f
+MAKE_ENV= pwrkdir=${WRKDIR}
+#"wrkdir" doesn't work for some reason in the above
# This will create dummy Makefiles and some links in the jpeg and libz
# subdirectories. This way, we do not need to hunt all the dependencies
# out. Shame on the lib's developers, though, this can not be done through
# `configure'. -mi
pre-build:
+ ${AR} -r ${WRKDIR}/libz.a /dev/null
+ ${RANLIB} ${WRKDIR}/libz.a
test -d ${WRKSRC}/hdf/jpeg.came-with-HDF || \
${MV} -f ${WRKSRC}/hdf/jpeg ${WRKSRC}/hdf/jpeg.came-with-HDF
-${MKDIR} ${WRKSRC}/hdf/jpeg
diff --git a/graphics/hdf5/scripts/post-patch b/graphics/hdf5/scripts/post-patch
index 1afaf52ab9ef..0922398e3d40 100644
--- a/graphics/hdf5/scripts/post-patch
+++ b/graphics/hdf5/scripts/post-patch
@@ -39,7 +39,7 @@ patch -p << END_OF_PATCH
-ZLIBINC=\$(srcdir)/../zlib
-ZLIBLIB=\$(srcdir)/../zlib
+ZLIBINC=/usr/include
-+ZLIBLIB=/usr/lib
++ZLIBLIB=-lz \$(pwrkdir)
END_OF_PATCH
done
@@ -51,7 +51,7 @@ patch -p << END_OF_PATCH
@@ -72,2 +72,2 @@
-ZLIBLIB=\$(srcdir)/../zlib
-ZLIBINC=\$(srcdir)/../zlib
-+ZLIBLIB=/usr/lib
++ZLIBLIB=-lz \$(pwrkdir)
+ZLIBINC=/usr/include
END_OF_PATCH
done