aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2003-05-19 09:07:18 +0800
committerpetef <petef@FreeBSD.org>2003-05-19 09:07:18 +0800
commitb4d92682d85aab81b87f2aa4ab29468054b5face (patch)
tree5519345abea942c4ddfddbe3b50ac6ba955f4a82 /graphics
parent27651dd18bc45d35d5342cd234854cf18cdac620 (diff)
downloadfreebsd-ports-gnome-b4d92682d85aab81b87f2aa4ab29468054b5face.tar.gz
freebsd-ports-gnome-b4d92682d85aab81b87f2aa4ab29468054b5face.tar.zst
freebsd-ports-gnome-b4d92682d85aab81b87f2aa4ab29468054b5face.zip
- respect CXXFLAGS/LDFLAGS
- bump PORTREVISION PR: 52275 Submitted by: Ports Fury
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gnofract4d/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index 3f2187c4e993..6804a89ad31b 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnofract4d
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,18 +15,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Weird GNOME fractal generator
-USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-compile-warnings=no
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "*Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-g -O2 -Wall -D_REENTRANT|\@CXXFLAGS\@|g ; \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|^CXXFLAGS =.* -D|CXXFLAGS = @CXXFLAGS@ -D|g ; \
s|gnofract4d_helpdir)/images|gnofract4d_helpdir)|g'
.include <bsd.port.mk>