aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-11-12 21:37:23 +0800
committerpav <pav@FreeBSD.org>2006-11-12 21:37:23 +0800
commitb5c789083ac3226cf7c025ded76212614a39f425 (patch)
tree61a8ac3aab52c2670b401b50baf60f787af67768 /graphics
parent76ebad3bdde7f1ea5311aae4d8080d2f36f77687 (diff)
downloadfreebsd-ports-gnome-b5c789083ac3226cf7c025ded76212614a39f425.tar.gz
freebsd-ports-gnome-b5c789083ac3226cf7c025ded76212614a39f425.tar.zst
freebsd-ports-gnome-b5c789083ac3226cf7c025ded76212614a39f425.zip
- Add a patch to not close shared dbus connections
PR: ports/105436 Submitted by: Christoph Moench-Tegeder <cmt@burggraben.net> Obtained from: gphoto svn
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libgphoto2/Makefile2
-rw-r--r--graphics/libgphoto2/files/patch-libgphoto2_port-disk-disk.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index 9e573436680a..1d1bf51f6da8 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libgphoto2
PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gphoto
diff --git a/graphics/libgphoto2/files/patch-libgphoto2_port-disk-disk.c b/graphics/libgphoto2/files/patch-libgphoto2_port-disk-disk.c
new file mode 100644
index 000000000000..4bbc2c9240b7
--- /dev/null
+++ b/graphics/libgphoto2/files/patch-libgphoto2_port-disk-disk.c
@@ -0,0 +1,10 @@
+--- libgphoto2_port/disk/disk.c.orig Wed Apr 19 03:54:26 2006
++++ libgphoto2_port/disk/disk.c Sun Nov 12 14:23:50 2006
+@@ -175,7 +175,6 @@
+
+ libhal_free_string_array (volumes);
+ libhal_ctx_free (ctx);
+- dbus_connection_disconnect (dbus_connection);
+ dbus_connection_unref (dbus_connection);
+ #else
+ # ifdef HAVE_MNTENT_H