aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2007-10-16 23:10:12 +0800
committeracm <acm@FreeBSD.org>2007-10-16 23:10:12 +0800
commitb6006409822ceedfba1a238edf1672777f9bb519 (patch)
tree50bb67e3fb10836df623e8715cf3600dc21d200d /graphics
parent524c565dfd4c23a1bd46ff9a7324b6cc9d4ae3f1 (diff)
downloadfreebsd-ports-gnome-b6006409822ceedfba1a238edf1672777f9bb519.tar.gz
freebsd-ports-gnome-b6006409822ceedfba1a238edf1672777f9bb519.tar.zst
freebsd-ports-gnome-b6006409822ceedfba1a238edf1672777f9bb519.zip
- Fix build with GCC 4.x
Diffstat (limited to 'graphics')
-rw-r--r--graphics/amanith/Makefile7
-rw-r--r--graphics/amanith/files/patch-examples-opengl-vectorizer_drawer.h11
2 files changed, 12 insertions, 6 deletions
diff --git a/graphics/amanith/Makefile b/graphics/amanith/Makefile
index 7bbf241bd940..4766ef7def06 100644
--- a/graphics/amanith/Makefile
+++ b/graphics/amanith/Makefile
@@ -7,7 +7,7 @@
PORTNAME= amanith
PORTVERSION= 0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://www.amanith.org/download/files/ \
http://louhi.kempele.fi/~skyostil/projects/pyamanith/dist/
@@ -21,7 +21,6 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype.9:${PORTSDIR}/print/freetype2
-USE_GCC= 3.4+
USE_QT_VER= 3
USE_XLIB= yes
USE_GL= yes
@@ -40,10 +39,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -i "" -e 's|3rdpart||' ${WRKSRC}/amanith.pro
diff --git a/graphics/amanith/files/patch-examples-opengl-vectorizer_drawer.h b/graphics/amanith/files/patch-examples-opengl-vectorizer_drawer.h
new file mode 100644
index 000000000000..2abec9c0aae2
--- /dev/null
+++ b/graphics/amanith/files/patch-examples-opengl-vectorizer_drawer.h
@@ -0,0 +1,11 @@
+--- examples/opengl/vectorizer/drawer.h 2007-10-16 10:03:21.000000000 -0500
++++ examples/opengl/vectorizer/drawer.h 2007-10-16 10:04:22.000000000 -0500
+@@ -71,7 +71,7 @@
+ #endif
+ // destructor
+ ~QGLWidgetTest();
+- void QGLWidgetTest::timerEvent(QTimerEvent *e);
++ void timerEvent(QTimerEvent *e);
+ };
+
+