aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-04-26 21:24:12 +0800
committermiwi <miwi@FreeBSD.org>2013-04-26 21:24:12 +0800
commitb892cdaced3250311365afa190a0ef12664e0a75 (patch)
treecb076a3270b780506c86fb5bcce8ad354807cd56 /graphics
parent3fa9006171bd4b94ba92a8729acc09749eb5d354 (diff)
downloadfreebsd-ports-gnome-b892cdaced3250311365afa190a0ef12664e0a75.tar.gz
freebsd-ports-gnome-b892cdaced3250311365afa190a0ef12664e0a75.tar.zst
freebsd-ports-gnome-b892cdaced3250311365afa190a0ef12664e0a75.zip
- Update to 0.3.2
PR: 178151 Submitted by: ports fury
Diffstat (limited to 'graphics')
-rw-r--r--graphics/swfmill/Makefile23
-rw-r--r--graphics/swfmill/distinfo4
-rw-r--r--graphics/swfmill/files/patch-readpng.c19
-rw-r--r--graphics/swfmill/pkg-descr9
-rw-r--r--graphics/swfmill/pkg-plist9
5 files changed, 17 insertions, 47 deletions
diff --git a/graphics/swfmill/Makefile b/graphics/swfmill/Makefile
index 1e54ca5e2fd4..245bb69d99c1 100644
--- a/graphics/swfmill/Makefile
+++ b/graphics/swfmill/Makefile
@@ -2,26 +2,25 @@
# $FreeBSD$
PORTNAME= swfmill
-PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTVERSION= 0.3.2
CATEGORIES= graphics
MASTER_SITES= http://swfmill.org/releases/
MAINTAINER= ports@FreeBSD.org
-COMMENT= xml2swf and swf2xml processor with import functionalities
+COMMENT= Tool to generate or decompile Adobe Flash SWF files
+
+LICENSE= GPLv2
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype:${PORTSDIR}/print/freetype2
+USES= pkgconfig
+USE_GNOME= libxml2 libxslt
+USE_ICONV= yes
+USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= pkgconfig libxml2 libxslt
-
-GNU_CONFIGURE= YES
-CONFIGURE_ENV+= PKG_CONFIG=${LOCALBASE}/bin/pkg-config
-
-USE_LDCONFIG= YES
+MAKE_JOBS_SAFE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|libpng|libpng15|' ${WRKSRC}/configure
+PLIST_FILES= bin/swfmill
.include <bsd.port.mk>
diff --git a/graphics/swfmill/distinfo b/graphics/swfmill/distinfo
index 9a3412eeeb25..635c3dc32faf 100644
--- a/graphics/swfmill/distinfo
+++ b/graphics/swfmill/distinfo
@@ -1,2 +1,2 @@
-SHA256 (swfmill-0.3.0.tar.gz) = dc6a8119f3435cebe6c0384760a4703e03c7ba26cf20dd319c6f81ad9e8a236b
-SIZE (swfmill-0.3.0.tar.gz) = 453486
+SHA256 (swfmill-0.3.2.tar.gz) = fea57ff9dc534b8e2340ebe64637493672ccb64a9811d95b49bf032c8c7bea1c
+SIZE (swfmill-0.3.2.tar.gz) = 1264450
diff --git a/graphics/swfmill/files/patch-readpng.c b/graphics/swfmill/files/patch-readpng.c
deleted file mode 100644
index 53c3d44c9172..000000000000
--- a/graphics/swfmill/files/patch-readpng.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/swft/readpng.c.orig 2009-11-30 01:18:53.000000000 +0100
-+++ src/swft/readpng.c 2012-05-05 07:48:08.000000000 +0200
-@@ -51,6 +51,7 @@
- #include <stdlib.h>
-
- #include "png.h" /* libpng header; includes zlib.h */
-+#include "zlib.h"
- #include "readpng.h" /* typedefs, common macros, public prototypes */
-
- /* future versions of libpng will provide this macro: */
-@@ -87,7 +88,7 @@
- * have used slightly more general png_sig_cmp() function instead */
-
- fread(sig, 1, 8, infile);
-- if (!png_check_sig(sig, 8))
-+ if (png_sig_cmp(sig, 0, 8))
- return 1; /* bad signature */
-
-
diff --git a/graphics/swfmill/pkg-descr b/graphics/swfmill/pkg-descr
index 83ce21e4a3d1..e886f5af669f 100644
--- a/graphics/swfmill/pkg-descr
+++ b/graphics/swfmill/pkg-descr
@@ -6,12 +6,11 @@ MTASC-compiled ActionScript, although swfmill can be used to produce
both simple and complex SWF structures.
* built around an XSLT/EXSLT processor (libxslt)
-
-* input and output of the XSLT transformation can be either XML or binary SWF
-
+* input and output of the XSLT transformation can be either XML or
+ binary SWF
* XSLT commands for importing PNG, JPEG, TTF and SWF, and for mapping
SWF ID numbers
-
-* built-in "simple dialect" to support library creation and building simple SWFs
+* built-in "simple dialect" to support library creation and building
+ simple SWFs
WWW: http://swfmill.org/
diff --git a/graphics/swfmill/pkg-plist b/graphics/swfmill/pkg-plist
deleted file mode 100644
index 0dc56d249fa7..000000000000
--- a/graphics/swfmill/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/swfmill
-lib/libswft.so.0
-lib/libswft.so
-lib/libswft.la
-lib/libswft.a
-lib/libswfmillxslt.so.0
-lib/libswfmillxslt.so
-lib/libswfmillxslt.la
-lib/libswfmillxslt.a