aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-10-14 16:01:13 +0800
committertcberner <tcberner@FreeBSD.org>2018-10-14 16:01:13 +0800
commitba96305a9a508696320d5c8513630f4f579d961f (patch)
treea24abebc7b4d4a1a4ecbd6f2f871ffd7f3a282ef /graphics
parentc4f589c9f3f52f3ae1ebb35dea0fcc3c8d5c603d (diff)
downloadfreebsd-ports-gnome-ba96305a9a508696320d5c8513630f4f579d961f.tar.gz
freebsd-ports-gnome-ba96305a9a508696320d5c8513630f4f579d961f.tar.zst
freebsd-ports-gnome-ba96305a9a508696320d5c8513630f4f579d961f.zip
qt5: Fix build on GCC based architectures.
PR: 231584 PR: 231677 PR: 231685 PR: 231830 PR: 231955 PR: 231905 PR: 231892 PR: 231684 PR: 231958 PR: 231960 PR: 231818 PR: 231542 PR: 231860 PR: 231681 PR: 231963 PR: 231891 PR: 231966 PR: 231904 PR: 231676 PR: 231819 PR: 231956 PR: 231680 PR: 231957 PR: 231903 PR: 231901 PR: 231667 PR: 231861 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/qt5-imageformats/Makefile2
-rw-r--r--graphics/qt5-opengl/Makefile2
-rw-r--r--graphics/qt5-svg/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/graphics/qt5-imageformats/Makefile b/graphics/qt5-imageformats/Makefile
index fe10cb544beb..46e33960b8a2 100644
--- a/graphics/qt5-imageformats/Makefile
+++ b/graphics/qt5-imageformats/Makefile
@@ -14,6 +14,6 @@ LIB_DEPENDS= libjasper.so:graphics/jasper \
libwebp.so:graphics/webp
USE_QT= core gui buildtools_build
-USES= localbase qmake qt-dist:5,imageformats
+USES= compiler:c++11-lang localbase qmake qt-dist:5,imageformats
.include <bsd.port.mk>
diff --git a/graphics/qt5-opengl/Makefile b/graphics/qt5-opengl/Makefile
index aeba157cc2e5..be001a76ef30 100644
--- a/graphics/qt5-opengl/Makefile
+++ b/graphics/qt5-opengl/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 5-compatible OpenGL support module
-USES= qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang gl qmake:no_env qt-dist:5,base
USE_GL= gl
USE_QT= core gui widgets qmake_build buildtools_build
HAS_CONFIGURE= yes
diff --git a/graphics/qt5-svg/Makefile b/graphics/qt5-svg/Makefile
index 27dc9bfb71d6..f02e59d7aec9 100644
--- a/graphics/qt5-svg/Makefile
+++ b/graphics/qt5-svg/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt SVG support module
USE_QT= core gui widgets buildtools_build
-USES= qmake qt-dist:5,svg
+USES= compiler:c++11-lang qmake qt-dist:5,svg
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>