aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-09-17 23:53:01 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-09-17 23:53:01 +0800
commitc267a387da82db042ecae50c5ac85e2c3bbe34d9 (patch)
tree51ac8104cf742bf6202bd658d50ac35fdfe1454d /graphics
parent3ea97e0761e68d04808d82e0b685843745d33dcf (diff)
downloadfreebsd-ports-gnome-c267a387da82db042ecae50c5ac85e2c3bbe34d9.tar.gz
freebsd-ports-gnome-c267a387da82db042ecae50c5ac85e2c3bbe34d9.tar.zst
freebsd-ports-gnome-c267a387da82db042ecae50c5ac85e2c3bbe34d9.zip
Fix build with clang/libc++
Diffstat (limited to 'graphics')
-rw-r--r--graphics/animorph/Makefile1
-rw-r--r--graphics/animorph/files/patch-include-animorph-util.h10
-rw-r--r--graphics/animorph/files/patch-src-BodySettings.cpp10
-rw-r--r--graphics/animorph/files/patch-src-FaceGroup.cpp10
-rw-r--r--graphics/animorph/files/patch-src-Hotspot.cpp10
-rw-r--r--graphics/makehuman/Makefile2
-rw-r--r--graphics/makehuman/files/patch-src-ComponentID.h11
-rw-r--r--graphics/makehuman/files/patch-src-FileTools.cpp11
-rw-r--r--graphics/mhgui/Makefile1
9 files changed, 65 insertions, 1 deletions
diff --git a/graphics/animorph/Makefile b/graphics/animorph/Makefile
index 27b3819b41f2..76cfab6c431c 100644
--- a/graphics/animorph/Makefile
+++ b/graphics/animorph/Makefile
@@ -15,6 +15,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USES= pkgconfig
USE_LDCONFIG= yes
+USE_GCC= yes # otherwise graphics/makehuman won't link
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/animorph/files/patch-include-animorph-util.h b/graphics/animorph/files/patch-include-animorph-util.h
new file mode 100644
index 000000000000..a8138c65dffa
--- /dev/null
+++ b/graphics/animorph/files/patch-include-animorph-util.h
@@ -0,0 +1,10 @@
+--- include/animorph/util.h.orig 2007-11-25 12:34:57.000000000 +0300
++++ include/animorph/util.h 2013-09-14 08:03:24.413227432 +0400
+@@ -37,6 +37,7 @@
+ #include <iomanip>
+ #include <vector>
+ #include <iostream>
++#include <cstdlib> // for atoi()
+ #include "Vector3.h"
+ #include "Vertex.h"
+ #include "VertexVector.h"
diff --git a/graphics/animorph/files/patch-src-BodySettings.cpp b/graphics/animorph/files/patch-src-BodySettings.cpp
new file mode 100644
index 000000000000..9bb6b9afc9e2
--- /dev/null
+++ b/graphics/animorph/files/patch-src-BodySettings.cpp
@@ -0,0 +1,10 @@
+--- src/BodySettings.cpp.orig 2007-12-03 01:30:41.000000000 +0300
++++ src/BodySettings.cpp 2013-09-17 17:25:49.896520104 +0400
+@@ -1,5 +1,7 @@
+ #include "../include/animorph/BodySettings.h"
+
++#include <cstring>
++
+ using namespace std;
+ using namespace Animorph;
+
diff --git a/graphics/animorph/files/patch-src-FaceGroup.cpp b/graphics/animorph/files/patch-src-FaceGroup.cpp
new file mode 100644
index 000000000000..6cf7ec73ef8f
--- /dev/null
+++ b/graphics/animorph/files/patch-src-FaceGroup.cpp
@@ -0,0 +1,10 @@
+--- src/FaceGroup.cpp.orig 2007-12-03 01:30:41.000000000 +0300
++++ src/FaceGroup.cpp 2013-09-17 17:56:37.772519994 +0400
+@@ -1,5 +1,7 @@
+ #include "../include/animorph/FaceGroup.h"
+
++#include <cstring>
++
+ using namespace std;
+ using namespace Animorph;
+
diff --git a/graphics/animorph/files/patch-src-Hotspot.cpp b/graphics/animorph/files/patch-src-Hotspot.cpp
new file mode 100644
index 000000000000..b0f815ac83f4
--- /dev/null
+++ b/graphics/animorph/files/patch-src-Hotspot.cpp
@@ -0,0 +1,10 @@
+--- src/Hotspot.cpp.orig 2007-11-25 12:34:58.000000000 +0300
++++ src/Hotspot.cpp 2013-09-17 17:32:58.043519323 +0400
+@@ -1,5 +1,7 @@
+ #include "../include/animorph/Hotspot.h"
+
++#include <cstring>
++
+ using namespace std;
+ using namespace Animorph;
+
diff --git a/graphics/makehuman/Makefile b/graphics/makehuman/Makefile
index 4f3338f534b7..0e5efa53776c 100644
--- a/graphics/makehuman/Makefile
+++ b/graphics/makehuman/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= animorph:${PORTSDIR}/graphics/animorph \
USES= gmake pkgconfig
GNU_CONFIGURE= yes
USE_GL= glut
-USE_GCC= any # Animation.cpp:94:26: error: variable length array of non-POD element type 'Animorph::BodySettings'
+USE_GCC= yes # Animation.cpp:94:26: error: variable length array of non-POD element type 'Animorph::BodySettings'
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/makehuman/files/patch-src-ComponentID.h b/graphics/makehuman/files/patch-src-ComponentID.h
new file mode 100644
index 000000000000..bd250e901626
--- /dev/null
+++ b/graphics/makehuman/files/patch-src-ComponentID.h
@@ -0,0 +1,11 @@
+--- src/ComponentID.h.orig 2007-12-03 01:30:18.000000000 +0300
++++ src/ComponentID.h 2013-09-14 14:26:25.451226331 +0400
+@@ -27,6 +27,8 @@
+ #ifndef COMPONENTID_H
+ #define COMPONENTID_H 1
+
++#include <algorithm> // for for_each in *Panel.cpp
++
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif
diff --git a/graphics/makehuman/files/patch-src-FileTools.cpp b/graphics/makehuman/files/patch-src-FileTools.cpp
new file mode 100644
index 000000000000..cf7a9da5d4c8
--- /dev/null
+++ b/graphics/makehuman/files/patch-src-FileTools.cpp
@@ -0,0 +1,11 @@
+--- src/FileTools.cpp.orig 2007-11-25 12:28:07.000000000 +0300
++++ src/FileTools.cpp 2013-09-17 06:11:17.036227572 +0400
+@@ -45,6 +45,8 @@
+ #include <dirent.h>
+ #include <limits.h>
+ #include <iostream>
++#include <cstdlib>
++#include <cstring>
+
+ /* ========================================================================== *
+ * FileTools - Implementation
diff --git a/graphics/mhgui/Makefile b/graphics/mhgui/Makefile
index ded631d2abeb..d7740c0b18b0 100644
--- a/graphics/mhgui/Makefile
+++ b/graphics/mhgui/Makefile
@@ -21,6 +21,7 @@ USES= pkgconfig
USE_LDCONFIG= yes
USE_XORG= xi xmu ice sm
USE_GL= glut
+USE_GCC= yes # otherwise graphics/makehuman won't link
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib