aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-12-24 02:01:50 +0800
committerstas <stas@FreeBSD.org>2006-12-24 02:01:50 +0800
commitc27aa601b0c80d8b683ce20497a4c0be62a3e665 (patch)
tree37a513c97e82003ef2d2c8b310b56bc47246582d /graphics
parentcf86c4bf478c3d44f3578042f1670b9ebe4b94af (diff)
downloadfreebsd-ports-gnome-c27aa601b0c80d8b683ce20497a4c0be62a3e665.tar.gz
freebsd-ports-gnome-c27aa601b0c80d8b683ce20497a4c0be62a3e665.tar.zst
freebsd-ports-gnome-c27aa601b0c80d8b683ce20497a4c0be62a3e665.zip
- Fix building with gcc41. The fix should be for really for xproto (c99
compatiblity), but it's not good to fix that now when the x11r7 import is planned.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/freeglut/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/freeglut/Makefile b/graphics/freeglut/Makefile
index 94f60e0b503d..95e9ef0cabcd 100644
--- a/graphics/freeglut/Makefile
+++ b/graphics/freeglut/Makefile
@@ -20,7 +20,8 @@ USE_LDCONFIG= yes
USE_XLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --x-includes=${X11BASE}/include \
- --x-libraries=${X11BASE}/lib
+ --x-libraries=${X11BASE}/lib \
+ --disable-warnings
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" LDFLAGS="-lusbhid"
REINPLACE_ARGS= -i ""