aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-05-30 19:42:38 +0800
committerbapt <bapt@FreeBSD.org>2012-05-30 19:42:38 +0800
commitc4321d275a768da79c5da5bb6b38163a55d2fad6 (patch)
tree2494fbf57893dc59a48babac84169c6f5a91f01c /graphics
parent4d7337c85aaf65424d3fce2838c3ca60793499a5 (diff)
downloadfreebsd-ports-gnome-c4321d275a768da79c5da5bb6b38163a55d2fad6.tar.gz
freebsd-ports-gnome-c4321d275a768da79c5da5bb6b38163a55d2fad6.tar.zst
freebsd-ports-gnome-c4321d275a768da79c5da5bb6b38163a55d2fad6.zip
Convert to new options framework
Diffstat (limited to 'graphics')
-rw-r--r--graphics/openclipart/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/openclipart/Makefile b/graphics/openclipart/Makefile
index 6287df5c524d..a8cb40c73a52 100644
--- a/graphics/openclipart/Makefile
+++ b/graphics/openclipart/Makefile
@@ -20,11 +20,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}${SVGPNG}
NO_BUILD= yes
PLIST= ${WRKDIR}/pkg-plist
-OPTIONS= PNG "Install png files" on
+OPTIONS_DEFINE= PNG
+OPTIONS_DEFAULT= PNG
+PNG_DESC= Install png files
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_PNG)
+.if ${PORT_OPTIONS:MPNG}
SVGPNG= -full
.else
SVGPNG= -svgonly
@@ -45,4 +47,4 @@ do-install:
@${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
@${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>