aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-08-22 17:07:49 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-08-22 17:07:49 +0800
commitc647088f38dc37eb21d31b5000faa379ec598f8e (patch)
treebafd3ca036388a43bbff2dab94226a04809969b1 /graphics
parentcb41cd9c301cf0f00626b9dac3ccc281b8e5ec53 (diff)
downloadfreebsd-ports-gnome-c647088f38dc37eb21d31b5000faa379ec598f8e.tar.gz
freebsd-ports-gnome-c647088f38dc37eb21d31b5000faa379ec598f8e.tar.zst
freebsd-ports-gnome-c647088f38dc37eb21d31b5000faa379ec598f8e.zip
- Sort LIB_DEPENDS
- Use REINPLACE_CMD instead of patch file - Cleanup Makefile - Update WWW and pkg-descr - Take maintainership
Diffstat (limited to 'graphics')
-rw-r--r--graphics/openjpeg/Makefile14
-rw-r--r--graphics/openjpeg/files/patch-CMakeLists.txt37
-rw-r--r--graphics/openjpeg/pkg-descr24
-rw-r--r--graphics/openjpeg/pkg-plist6
4 files changed, 26 insertions, 55 deletions
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
index 0d32394db9e2..54a097f9c924 100644
--- a/graphics/openjpeg/Makefile
+++ b/graphics/openjpeg/Makefile
@@ -4,21 +4,23 @@
PORTNAME= openjpeg
PORTVERSION= 2.1.0
CATEGORIES= graphics
-MASTER_SITES= SF/openjpeg.mirror/${PORTVERSION}/
-#??
+MASTER_SITES= SF/openjpeg.mirror/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Open-source JPEG 2000 codec
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
+LIB_DEPENDS= liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libpng15.so:${PORTSDIR}/graphics/png \
- liblcms2.so:${PORTSDIR}/graphics/lcms2
+ libtiff.so:${PORTSDIR}/graphics/tiff
-USES= cmake pkgconfig
USE_LDCONFIG= yes
+USES= cmake pkgconfig
PLIST_SUB= VER=${PORTVERSION:R}
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${OPENJPEG_INSTALL_LIB_DIR}/pkgconfig|libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.mk>
diff --git a/graphics/openjpeg/files/patch-CMakeLists.txt b/graphics/openjpeg/files/patch-CMakeLists.txt
deleted file mode 100644
index 49af929acfa5..000000000000
--- a/graphics/openjpeg/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,37 +0,0 @@
---- CMakeLists.txt.orig 2014-05-23 22:46:07.000000000 +0200
-+++ CMakeLists.txt 2014-05-23 22:48:32.000000000 +0200
-@@ -334,14 +334,14 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/lib/openjp2/libopenjp2.pc.cmake.in
- ${CMAKE_CURRENT_BINARY_DIR}/libopenjp2.pc @ONLY)
- install( FILES ${CMAKE_CURRENT_BINARY_DIR}/libopenjp2.pc DESTINATION
-- ${OPENJPEG_INSTALL_LIB_DIR}/pkgconfig )
-+ libdata/pkgconfig )
- #
- if(BUILD_JPWL)
- # install in lib and not share (see multi-arch note above)
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/lib/openjpwl/libopenjpwl.pc.cmake.in
- ${CMAKE_CURRENT_BINARY_DIR}/libopenjpwl.pc @ONLY)
- install( FILES ${CMAKE_CURRENT_BINARY_DIR}/libopenjpwl.pc DESTINATION
-- ${OPENJPEG_INSTALL_LIB_DIR}/pkgconfig )
-+ libdata/pkgconfig )
- endif()
- #
- if(BUILD_JPIP)
-@@ -349,7 +349,7 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/lib/openjpip/libopenjpip.pc.cmake.in
- ${CMAKE_CURRENT_BINARY_DIR}/libopenjpip.pc @ONLY)
- install( FILES ${CMAKE_CURRENT_BINARY_DIR}/libopenjpip.pc DESTINATION
-- ${OPENJPEG_INSTALL_LIB_DIR}/pkgconfig )
-+ libdata/pkgconfig )
- endif()
- #
- if(BUILD_JP3D)
-@@ -357,7 +357,7 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/lib/openjp3d/libopenjp3d.pc.cmake.in
- ${CMAKE_CURRENT_BINARY_DIR}/libopenjp3d.pc @ONLY)
- install( FILES ${CMAKE_CURRENT_BINARY_DIR}/libopenjp3d.pc DESTINATION
-- ${OPENJPEG_INSTALL_LIB_DIR}/pkgconfig )
-+ libdata/pkgconfig )
- endif()
- endif()
-
diff --git a/graphics/openjpeg/pkg-descr b/graphics/openjpeg/pkg-descr
index ce3b146262d8..055e519a8d66 100644
--- a/graphics/openjpeg/pkg-descr
+++ b/graphics/openjpeg/pkg-descr
@@ -1,10 +1,16 @@
-The OpenJPEG library is an open-source JPEG 2000 codec written in
-C language. It has been developed in order to promote the use of
-JPEG 2000, the new still-image compression standard from the Joint
-Photographic Experts Group (JPEG). In addition to the basic codec,
-various other features are under development, among them the JP2
-and MJ2 (Motion JPEG 2000) file formats, an indexing tool useful
-for the JPIP protocol, JPWL-tools for error-resilience, a Java-viewer
-for j2k-images, ...
+The OpenJPEG library is an open-source JPEG 2000 library developed in order to
+promote the use of JPEG 2000.
-WWW: http://code.google.com/p/openjpeg/
+The main part of the project consists in a JPEG 2000 codec compliant with the
+Part 1 of the standard (Class-1 Profile-1 compliance).
+
+Besides this main codec, OpenJPEG integrates several other modules:
+- JP2 (JPEG 2000 standard Part 2 - Handling of JP2 boxes and extended multiple
+ component transforms for multispectral and hyperspectral imagery)
+- MJ2 (JPEG 2000 standard Part 3)
+- JPWL (JPEG 2000 standard Part 11)
+- JPIP (JPEG 2000 standard Part 9)
+- OPJViewer, a GUI viewer for J2K, JP2, JPWL and MJ2 files
+
+WWW: https://code.google.com/p/openjpeg/
+WWW: http://openjpeg.mirror.sourceforge.net/
diff --git a/graphics/openjpeg/pkg-plist b/graphics/openjpeg/pkg-plist
index 8d0234b7c6f1..d7d990d7e35f 100644
--- a/graphics/openjpeg/pkg-plist
+++ b/graphics/openjpeg/pkg-plist
@@ -5,11 +5,11 @@ include/openjpeg-%%VER%%/openjpeg.h
include/openjpeg-%%VER%%/opj_config.h
include/openjpeg-%%VER%%/opj_stdint.h
lib/libopenjp2.so
-lib/libopenjp2.so.2.1.0
+lib/libopenjp2.so.%%VER%%.0
lib/libopenjp2.so.7
lib/openjpeg-%%VER%%/OpenJPEGConfig.cmake
lib/openjpeg-%%VER%%/OpenJPEGTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/openjpeg-%%VER%%/OpenJPEGTargets.cmake
libdata/pkgconfig/libopenjp2.pc
-@dirrmtry lib/openjpeg-%%VER%%
-@dirrmtry include/openjpeg-%%VER%%
+@dirrm lib/openjpeg-%%VER%%
+@dirrm include/openjpeg-%%VER%%