aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-11-24 21:40:53 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-11-24 21:40:53 +0800
commitcb056d2f79512309d760b5d027a68d428ebbb75b (patch)
tree6b62f0ca7c0fec3f4ef9f8742cecf6dd841b334b /graphics
parentcf7b2a5a6ed4d41a8b3af54d7157d20b27b47e75 (diff)
downloadfreebsd-ports-gnome-cb056d2f79512309d760b5d027a68d428ebbb75b.tar.gz
freebsd-ports-gnome-cb056d2f79512309d760b5d027a68d428ebbb75b.tar.zst
freebsd-ports-gnome-cb056d2f79512309d760b5d027a68d428ebbb75b.zip
Nathive is a libre software image editor, similar to Adobe Photoshop,
Corel Photo-Paint or The GIMP, but focused on usability, logic and providing a smooth learning curve for everyone. The project run in the Gnome desktop environment and anyone is welcome to collaborate on it with code, translations or ideas. This project is in the alpha phase, so it is an incomplete work, unfit for the end user yet. The intention is to achieve a professional graphic editor progressively without giving up initial usability. Nathive is written from scratch in C using GTK+, and is designed to be simple, lightweight, and easy to install and use. WWW: http://www.nathive.org/
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/nathive/Makefile36
-rw-r--r--graphics/nathive/distinfo3
-rw-r--r--graphics/nathive/pkg-descr13
-rw-r--r--graphics/nathive/pkg-plist26
5 files changed, 79 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 2a1103093aeb..095b27327565 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -478,6 +478,7 @@
SUBDIR += multivideo
SUBDIR += mxp
SUBDIR += mypaint
+ SUBDIR += nathive
SUBDIR += netpbm
SUBDIR += netpbm-devel
SUBDIR += nip2
diff --git a/graphics/nathive/Makefile b/graphics/nathive/Makefile
new file mode 100644
index 000000000000..93e681d0eae9
--- /dev/null
+++ b/graphics/nathive/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: nathive
+# Date created: 24 Nov 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nathive
+PORTVERSION= 0.811
+CATEGORIES= graphics
+MASTER_SITES= http://www.nathive.org/packages/ \
+ http://www.amdmi3.ru/distfiles/
+DISTNAME= ${PORTNAME}_${PORTVERSION}_source
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Lightweight image editor
+
+USE_GNOME= pkgconfig glib20 gtk20
+NO_WRKSUBDIR= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e '/define.*PATH/ s|".*"|"${DATADIR}/"|' \
+ ${WRKSRC}/nathive.c
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} `pkg-config --cflags --libs glib-2.0` \
+ `pkg-config --cflags --libs gtk+-2.0` nathive.c -o nathive
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nathive ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} "cfg img lang palettes text" ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/graphics/nathive/distinfo b/graphics/nathive/distinfo
new file mode 100644
index 000000000000..ee18d6d67b8f
--- /dev/null
+++ b/graphics/nathive/distinfo
@@ -0,0 +1,3 @@
+MD5 (nathive_0.811_source.tar.gz) = 5909b2a3110dd4cfbde1d54a35cc7320
+SHA256 (nathive_0.811_source.tar.gz) = 223fed97ef2152faf858f2a1bfee661d6d6415d408ac29ca4b89a7d5ae5fd042
+SIZE (nathive_0.811_source.tar.gz) = 62227
diff --git a/graphics/nathive/pkg-descr b/graphics/nathive/pkg-descr
new file mode 100644
index 000000000000..f186e8477c46
--- /dev/null
+++ b/graphics/nathive/pkg-descr
@@ -0,0 +1,13 @@
+Nathive is a libre software image editor, similar to Adobe Photoshop,
+Corel Photo-Paint or The GIMP, but focused on usability, logic and
+providing a smooth learning curve for everyone. The project run in
+the Gnome desktop environment and anyone is welcome to collaborate
+on it with code, translations or ideas.
+
+This project is in the alpha phase, so it is an incomplete work,
+unfit for the end user yet. The intention is to achieve a professional
+graphic editor progressively without giving up initial usability.
+Nathive is written from scratch in C using GTK+, and is designed
+to be simple, lightweight, and easy to install and use.
+
+WWW: http://www.nathive.org/
diff --git a/graphics/nathive/pkg-plist b/graphics/nathive/pkg-plist
new file mode 100644
index 000000000000..6f62b63fe78f
--- /dev/null
+++ b/graphics/nathive/pkg-plist
@@ -0,0 +1,26 @@
+bin/nathive
+%%DATADIR%%/cfg/cfg.xml
+%%DATADIR%%/img/about.png
+%%DATADIR%%/img/brush.png
+%%DATADIR%%/img/circle.png
+%%DATADIR%%/img/icon.png
+%%DATADIR%%/img/mask.png
+%%DATADIR%%/img/picker.png
+%%DATADIR%%/img/select.png
+%%DATADIR%%/img/square.png
+%%DATADIR%%/lang/chinese.xml
+%%DATADIR%%/lang/english.xml
+%%DATADIR%%/lang/german.xml
+%%DATADIR%%/lang/hungarian.xml
+%%DATADIR%%/lang/polish.xml
+%%DATADIR%%/lang/spanish.xml
+%%DATADIR%%/palettes/01.xml
+%%DATADIR%%/palettes/02.xml
+%%DATADIR%%/text/credits
+%%DATADIR%%/text/license
+@dirrm %%DATADIR%%/text
+@dirrm %%DATADIR%%/palettes
+@dirrm %%DATADIR%%/lang
+@dirrm %%DATADIR%%/img
+@dirrm %%DATADIR%%/cfg
+@dirrm %%DATADIR%%