aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-11 07:15:20 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-11 07:15:20 +0800
commitcdc7bf65ea01ab4c535a1dc4eddfa2fc6d961718 (patch)
treed2231ef6235b13bfb69cbd25b924db95df167580 /graphics
parent560f9c44eea9b9ce944e06a5a5adcd4e0c10581c (diff)
downloadfreebsd-ports-gnome-cdc7bf65ea01ab4c535a1dc4eddfa2fc6d961718.tar.gz
freebsd-ports-gnome-cdc7bf65ea01ab4c535a1dc4eddfa2fc6d961718.tar.zst
freebsd-ports-gnome-cdc7bf65ea01ab4c535a1dc4eddfa2fc6d961718.zip
- Convert to new options target helper
Approved by: portmgr (blanket)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libbpg/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/graphics/libbpg/Makefile b/graphics/libbpg/Makefile
index 5b9c441c0848..32ba216edc75 100644
--- a/graphics/libbpg/Makefile
+++ b/graphics/libbpg/Makefile
@@ -29,28 +29,22 @@ USES= compiler:c++11-lib gmake jpeg
CFLAGS+= -fPIC -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.options.mk>
+do-configure-JCTVC-off:
+ ${REINPLACE_CMD} -e 's/^USE_JCTVC=y$$/#USE_JCTVC=/' ${WRKSRC}/Makefile
-do-configure:
-.if ! ${PORT_OPTIONS:MSDL}
+do-configure-SDL-off:
${REINPLACE_CMD} -e 's/^USE_BPGVIEW=y$$/#USE_BPGVIEW=/' ${WRKSRC}/Makefile
-.endif
-.if ! ${PORT_OPTIONS:MJCTVC}
- ${REINPLACE_CMD} -e 's/^USE_JCTVC=y$$/#USE_JCTVC=/' ${WRKSRC}/Makefile
-.endif
-.if ${PORT_OPTIONS:MX265}
+
+do-configure-X265-on:
${REINPLACE_CMD} -e 's/^#USE_JCTVC_HIGH_BIT_DEPTH=y$$/USE_JCTVC_HIGH_BIT_DEPTH=y/' ${WRKSRC}/Makefile
-.endif
-.if ${PORT_OPTIONS:MX265}
${REINPLACE_CMD} -e 's/^#USE_X265=y$$/USE_X265=y/' ${WRKSRC}/Makefile
-.endif
post-install:
-.if ${PORT_OPTIONS:MSDL}
- ${INSTALL_PROGRAM} ${WRKSRC}/bpgview ${STAGEDIR}${PREFIX}/bin
-.endif
${INSTALL_DATA} ${WRKSRC}/libbpg.h ${STAGEDIR}${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/libbpg.a ${STAGEDIR}${PREFIX}/lib
${INSTALL_LIB} ${WRKSRC}/libbpg.so ${STAGEDIR}${PREFIX}/lib
+post-install-SDL-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bpgview ${STAGEDIR}${PREFIX}/bin
+
.include <bsd.port.mk>