aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-05-22 06:23:08 +0800
committerlofi <lofi@FreeBSD.org>2004-05-22 06:23:08 +0800
commitd1252614215048e822b94df6cd1e90a8767f993e (patch)
tree22bd2f5189af01a1fe3bdbd91ee107fd761f6d72 /graphics
parent695e0248a64772c504f0bbe819b884fc235f7ebc (diff)
downloadfreebsd-ports-gnome-d1252614215048e822b94df6cd1e90a8767f993e.tar.gz
freebsd-ports-gnome-d1252614215048e822b94df6cd1e90a8767f993e.tar.zst
freebsd-ports-gnome-d1252614215048e822b94df6cd1e90a8767f993e.zip
Remove inclusion of "${PORTSDIR}/x11/kde3/Makefile.kde", fix PTHREAD_LIBS
safeness, fix compilation where needed. Committers: Please do NOT include Makefile.kde or commit new ports which do so. It's for use with the core KDE ports maintained by kde@freebsd.org ONLY.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/kbarcode/Makefile9
-rw-r--r--graphics/kbarcode/files/patch-kbarcode_Makefile.in11
2 files changed, 17 insertions, 3 deletions
diff --git a/graphics/kbarcode/Makefile b/graphics/kbarcode/Makefile
index 0bd4bae10b82..98cb258316b2 100644
--- a/graphics/kbarcode/Makefile
+++ b/graphics/kbarcode/Makefile
@@ -20,7 +20,10 @@ RUN_DEPENDS= barcode:${PORTSDIR}/graphics/barcode
USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/graphics/kbarcode/files/patch-kbarcode_Makefile.in b/graphics/kbarcode/files/patch-kbarcode_Makefile.in
new file mode 100644
index 000000000000..3c25aa57f269
--- /dev/null
+++ b/graphics/kbarcode/files/patch-kbarcode_Makefile.in
@@ -0,0 +1,11 @@
+--- kbarcode/Makefile.in.orig Fri May 21 23:23:23 2004
++++ kbarcode/Makefile.in Fri May 21 23:24:01 2004
+@@ -259,7 +259,7 @@
+
+ # the application source, library search path, and link libraries
+ kbarcode_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+-kbarcode_LDADD = $(LIB_KABC) $(LIB_KSPELL) $(LIB_KDEPRINT) $(LIB_KDEUI)
++kbarcode_LDADD = $(LIB_KABC) $(LIB_KSPELL) $(LIB_KDEPRINT) $(LIB_KDEUI) $(LIBPTHREAD)
+ noinst_HEADERS = barcodecache.h barcodecombo.h barcodedialog.h barcodedialogs.h commands.h configdialog.h confwizard.h csvimportdlg.h databasebrowser.h definition.h definitiondialog.h dsmainwindow.h dsrichtext.h kbarcode.h label.h labeleditor.h labelprinter.h labelutils.h mimesources.h multilineeditdlg.h mybarcode.h mycanvasitem.h mycanvasview.h mydatatable.h newlabel.h previewdialog.h printersettings.h printlabeldlg.h rectsettingsdlg.h smalldialogs.h sqltables.h tokenprovider.h xmlutils.h zplutils.h
+ kbarcode_SOURCES = barcodecombo.cpp barcodecache.cpp barcodedialog.cpp barcodedialogs.cpp commands.cpp configdialog.cpp confwizard.cpp csvimportdlg.cpp databasebrowser.cpp definition.cpp definitiondialog.cpp dsmainwindow.cpp dsrichtext.cpp kbarcode.cpp label.cpp labeleditor.cpp labelprinter.cpp labelutils.cpp main.cpp mimesources.cpp multilineeditdlg.cpp mybarcode.cpp mycanvasitem.cpp mycanvasview.cpp mydatatable.cpp newlabel.cpp previewdialog.cpp printersettings.cpp printlabeldlg.cpp rectsettingsdlg.cpp smalldialogs.cpp sqltables.cpp tokenprovider.cpp xmlutils.cpp zplutils.cpp
+