aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-08-26 12:05:38 +0800
committerMartin Wilke <miwi@FreeBSD.org>2011-08-26 12:05:38 +0800
commitd24d4d2dda63ccd5d3d2d1cf4ea8b1a9dbae37a3 (patch)
treea7ed288745dde44db61bd4bff1787503744df443 /graphics
parentb96c3bba39317e1dee7406eeec2763450a10842e (diff)
downloadfreebsd-ports-gnome-d24d4d2dda63ccd5d3d2d1cf4ea8b1a9dbae37a3.tar.gz
freebsd-ports-gnome-d24d4d2dda63ccd5d3d2d1cf4ea8b1a9dbae37a3.tar.zst
freebsd-ports-gnome-d24d4d2dda63ccd5d3d2d1cf4ea8b1a9dbae37a3.zip
- Update MASTER_SITES and WWW: line
- Add LICENSE - Add MAKE_JOBS_SAFE PR: 160118 Submitted by: Ports Fury
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libgfx/Makefile40
-rw-r--r--graphics/libgfx/pkg-descr2
2 files changed, 25 insertions, 17 deletions
diff --git a/graphics/libgfx/Makefile b/graphics/libgfx/Makefile
index 6e26d18d731c..770caf37a860 100644
--- a/graphics/libgfx/Makefile
+++ b/graphics/libgfx/Makefile
@@ -9,40 +9,48 @@ PORTNAME= libgfx
DISTVERSION= 1.1.0
PORTREVISION= 6
CATEGORIES= graphics
-MASTER_SITES= http://graphics.cs.uiuc.edu/~garland/dist/ CENKES
+MASTER_SITES= http://mgarland.org/files/dist/
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL/FLTK development
+LICENSE= MIT
+
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
tiff.4:${PORTSDIR}/graphics/tiff \
png.6:${PORTSDIR}/graphics/png \
gzstream.0:${PORTSDIR}/devel/gzstream \
jpeg.11:${PORTSDIR}/graphics/jpeg
-USE_GL= gl
+BUILD_WRKSRC= ${WRKSRC}/src
+
+USE_GL= glu
USE_GMAKE= yes
-USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-gzstream --with-libtiff-lzw --with-x
-CFLAGS= -I${LOCALBASE}/include -fPIC
-LDFLAGS= -L${LOCALBASE}/lib
-BUILD_WRKSRC= ${WRKSRC}/src
ALL_TARGET= ${PORTNAME}.so
-MAKE_ARGS= CC="${CC}" CXX="${CXX}"
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+CFLAGS+= -fPIC
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e '/^CC /d;/^CXX /d' ${WRKSRC}/gfx-config.in
- @${REINPLACE_CMD} -e 's|\.a|.so|g;/RANLIB/d;s|[(]AR[)] cru|{CC} \
- ${CFLAGS} ${LDFLAGS} -shared $${GUI_LIBS} -lgzstream -o|'\
- ${WRKSRC}/src/${MAKEFILE}
- @${REINPLACE_CMD} -e '6115s|-lfltk|`fltk-config --ldflags`|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/^CC /d ; \
+ /^CXX /d' ${WRKSRC}/gfx-config.in
+ @${REINPLACE_CMD} -e \
+ 's|\.a|.so|g ; \
+ /RANLIB/d ; \
+ s|[(]AR[)] cru|{CC} ${CFLAGS} ${LDFLAGS} -shared $${GUI_LIBS} -lgzstream -o|' ${WRKSRC}/src/${MAKEFILE}
+ @${REINPLACE_CMD} -e \
+ '/^FLTK_LIBS/s|"-lfltk"|"`fltk-config --ldflags`"|' ${WRKSRC}/configure
do-install:
- @cd ${WRKSRC}/include/gfx/&&${COPYTREE_SHARE} . ${PREFIX}/include/gfx/
- @${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}.so ${PREFIX}/lib/
+ @(cd ${WRKSRC}/include/gfx && ${COPYTREE_SHARE} . ${PREFIX}/include/gfx)
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}.so ${PREFIX}/lib
@${LN} -sf ${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.0
.include <bsd.port.mk>
diff --git a/graphics/libgfx/pkg-descr b/graphics/libgfx/pkg-descr
index 1fa21a9aff44..bba81b87b96a 100644
--- a/graphics/libgfx/pkg-descr
+++ b/graphics/libgfx/pkg-descr
@@ -6,4 +6,4 @@ to provide facilities which are useful in the majority of graphics programs.
This release introduces some (relatively small) incompatible changes with
1.0.x versions of the library. Details on changes can be found below.
-WWW: http://graphics.cs.uiuc.edu/~garland/software/libgfx.html
+WWW: http://mgarland.org/software/libgfx.html