aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2013-05-24 16:47:33 +0800
committeraraujo <araujo@FreeBSD.org>2013-05-24 16:47:33 +0800
commitd3352f2cfd96e2eb98e87336690754174d67fc49 (patch)
tree94eca8e04eb9b66b811e3ea2792b054f002111ef /graphics
parent76bfa7ee304c4fa803d64aca7726beb465123830 (diff)
downloadfreebsd-ports-gnome-d3352f2cfd96e2eb98e87336690754174d67fc49.tar.gz
freebsd-ports-gnome-d3352f2cfd96e2eb98e87336690754174d67fc49.tar.zst
freebsd-ports-gnome-d3352f2cfd96e2eb98e87336690754174d67fc49.zip
- Update MASTER_SITES.
- Add LICENSE. - Add MAKE_JOBS_SAFE. - Fix options for GIMP support. PR: ports/172240 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sane-frontends/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/graphics/sane-frontends/Makefile b/graphics/sane-frontends/Makefile
index 953fbd2aeffd..62e0ccbf92d7 100644
--- a/graphics/sane-frontends/Makefile
+++ b/graphics/sane-frontends/Makefile
@@ -1,30 +1,24 @@
-# New ports collection makefile for: sane-frontends
-# Date created: Sat Jul 19 16:23:10 MET DST 1997
-# Whom: gary@hotlava.com
-#
+# Created by: gary@hotlava.com
# $FreeBSD$
-#
PORTNAME= sane-frontends
PORTVERSION= 1.0.14
PORTREVISION= 8
CATEGORIES= graphics
MASTER_SITES= http://alioth.debian.org/frs/download.php/1140/ \
- ftp://ftp.sane-project.org/pub/sane/%SUBDIR%/ \
- ftp://ftp2.sane-project.org/pub/sane/%SUBDIR%/ \
- ftp://ftp3.sane-project.org/pub/sane/%SUBDIR%/ \
- ftp://gd.tuwien.ac.at/hci/sane/%SUBDIR%/ \
- http://gd.tuwien.ac.at/hci/sane/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
+ ftp://ftp2.sane-project.org/pub/sane/
MAINTAINER= ports@FreeBSD.org
COMMENT= Tools for access to scanners, digitals camera, frame grabbers etc
-LIB_DEPENDS= sane.1:${PORTSDIR}/graphics/sane-backends
+LICENSE= GPLv2 # (or later)
+
+LIB_DEPENDS= sane:${PORTSDIR}/graphics/sane-backends
USE_GMAKE= yes
-WANT_GNOME= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -44,7 +38,7 @@ CONFIGURE_ARGS+= --disable-gimp
.else
USE_GNOME+= gtk20
.if ${PORT_OPTIONS:MGIMP}
-LIB_DEPENDS+= gimp-2.0:${PORTSDIR}/graphics/gimp
+LIB_DEPENDS+= gimp-2.0:${PORTSDIR}/graphics/gimp-app
CONFIGURE_ARGS+= --enable-gimp
.else
CONFIGURE_ARGS+= --disable-gimp