aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-12 17:01:29 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-12 17:01:29 +0800
commitdbf45927a9ba7df38fe431881e0db6d759544475 (patch)
tree9a9add8e454c207f5cf16f53afff60f6f4bd8d76 /graphics
parentfcd0f7cf73c659c09de81478c0bf29ba922da547 (diff)
downloadfreebsd-ports-gnome-dbf45927a9ba7df38fe431881e0db6d759544475.tar.gz
freebsd-ports-gnome-dbf45927a9ba7df38fe431881e0db6d759544475.tar.zst
freebsd-ports-gnome-dbf45927a9ba7df38fe431881e0db6d759544475.zip
- Add LICENSE
- Switch to options helpers - Cosmetic fixes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/deegree-wms/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/deegree-wms/Makefile b/graphics/deegree-wms/Makefile
index 66698ed78fee..5a9f77f9361a 100644
--- a/graphics/deegree-wms/Makefile
+++ b/graphics/deegree-wms/Makefile
@@ -34,14 +34,14 @@ OPTIONS_DEFINE= DOCS
.if ${PORT_OPTIONS:MTOMCAT6}
TOMCATVER= apache-tomcat-6.0
-TCPORT= 8180
+TCPORT= 8180
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat6
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat6
.endif
.if ${PORT_OPTIONS:MTOMCAT7}
TOMCATVER= apache-tomcat-7.0
-TCPORT= 8080
+TCPORT= 8080
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat7
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat7
.endif
@@ -51,9 +51,11 @@ post-extract:
@${TAR} xf ${WRKDIR}/deegree-wms.war -C ${WRKDIR}/${PORTDIRNAME}
do-install:
- ${INSTALL} -d ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
+ @${MKDIR} ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>