aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-06-22 00:01:47 +0800
committergarga <garga@FreeBSD.org>2006-06-22 00:01:47 +0800
commitdbf507a6f76c7e6b04ceb86a5b1510f19e11028a (patch)
treef34e72c4377d3f96c3d00a53688115732332f321 /graphics
parent9f337ea6c1cf086bd2f135b593cb066ed0440e1f (diff)
downloadfreebsd-ports-gnome-dbf507a6f76c7e6b04ceb86a5b1510f19e11028a.tar.gz
freebsd-ports-gnome-dbf507a6f76c7e6b04ceb86a5b1510f19e11028a.tar.zst
freebsd-ports-gnome-dbf507a6f76c7e6b04ceb86a5b1510f19e11028a.zip
Add fpc-opengl , free Pascal interface to the OpenGL library.
PR: ports/98674 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/fpc-opengl/Makefile21
2 files changed, 22 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4aab2d007e9b..69fdc5cdf268 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -131,6 +131,7 @@
SUBDIR += fpc-libgd
SUBDIR += fpc-libpng
SUBDIR += fpc-ncurses
+ SUBDIR += fpc-opengl
SUBDIR += fracplanet
SUBDIR += fractorama
SUBDIR += fraqtive
diff --git a/graphics/fpc-opengl/Makefile b/graphics/fpc-opengl/Makefile
new file mode 100644
index 000000000000..5bd4f598c0a9
--- /dev/null
+++ b/graphics/fpc-opengl/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: fpc-opengl
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics lang
+PKGNAMESUFFIX= -opengl
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free Pascal interface to the OpenGL library
+
+RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
+USE_GL= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+
+.include "${MASTERDIR}/Makefile"