aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-12-29 23:53:51 +0800
committermiwi <miwi@FreeBSD.org>2011-12-29 23:53:51 +0800
commite08e1abc8f8698d5621a515d649d03ece3cd9cb6 (patch)
treee4d634d155aae75b8a1f007bba44c980fe3c83c6 /graphics
parent04ffdc59849a256f2e7cd4c4295a5e43a5fac80e (diff)
downloadfreebsd-ports-gnome-e08e1abc8f8698d5621a515d649d03ece3cd9cb6.tar.gz
freebsd-ports-gnome-e08e1abc8f8698d5621a515d649d03ece3cd9cb6.tar.zst
freebsd-ports-gnome-e08e1abc8f8698d5621a515d649d03ece3cd9cb6.zip
- Fix build with clang
PR: 162915 Submitted by: Jan Beich <jbeich@tormail.net>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/glfw/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 0ab213034da8..6a575e1e5a34 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -29,6 +29,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/X11R6|${X11BASE}| ; \
+ /SOFLAGS/s|-soname |-Wl,-soname,| ; \
/CFLAGS_THREAD/s|"-pthread"|"${PTHREAD_CFLAGS}"| ; \
/LFLAGS_THREAD/s|"-pthread"|"${PTHREAD_LIBS}"|' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e \