aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-04-23 04:36:25 +0800
committerdinoex <dinoex@FreeBSD.org>2013-04-23 04:36:25 +0800
commite1f064e1c4c03dbacd5e8ed253ae269b46b9c235 (patch)
tree084dabfc2c91a5ce236a3c5ff1e4d066280a011d /graphics
parent456b4f7bba5d997dfe68aab601ebbac3876c49e3 (diff)
downloadfreebsd-ports-gnome-e1f064e1c4c03dbacd5e8ed253ae269b46b9c235.tar.gz
freebsd-ports-gnome-e1f064e1c4c03dbacd5e8ed253ae269b46b9c235.tar.zst
freebsd-ports-gnome-e1f064e1c4c03dbacd5e8ed253ae269b46b9c235.zip
- use bsd.port.options.mk
PR: 177324
Diffstat (limited to 'graphics')
-rw-r--r--graphics/hobbes-icons-xpm/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/graphics/hobbes-icons-xpm/Makefile b/graphics/hobbes-icons-xpm/Makefile
index fc5d2b4e766a..348525ab20bd 100644
--- a/graphics/hobbes-icons-xpm/Makefile
+++ b/graphics/hobbes-icons-xpm/Makefile
@@ -16,18 +16,20 @@ NO_BUILD= yes
# Where it will be installed (change pkg/PLIST if you change this)
LIBDIR= ${PREFIX}/include/X11/pixmaps
+.include <bsd.port.options.mk>
+
do-install:
- @${MKDIR} ${LIBDIR}
+ ${MKDIR} ${LIBDIR}
${CP} -R ${WRKSRC}/* ${LIBDIR}
${CHOWN} -R ${BINOWN}:${BINGRP} ${LIBDIR}
-${RM} ${LIBDIR}/README
-${RM} ${LIBDIR}/readem.shar
+.if ${PORT_OPTIONS:MDOCS}
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- @${INSTALL_SCRIPT} ${WRKSRC}/*.shar ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.shar ${DOCSDIR}/
.endif
.include <bsd.port.mk>