aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2016-04-22 00:48:50 +0800
committergahr <gahr@FreeBSD.org>2016-04-22 00:48:50 +0800
commite256b474346f69fed7a7b4bfd454e2afe3107bf9 (patch)
treed0c1f5dd5ca5ac27d60728de7479d49195932db9 /graphics
parent846d8199972dd0559fe10d7173837b7a0309069b (diff)
downloadfreebsd-ports-gnome-e256b474346f69fed7a7b4bfd454e2afe3107bf9.tar.gz
freebsd-ports-gnome-e256b474346f69fed7a7b4bfd454e2afe3107bf9.tar.zst
freebsd-ports-gnome-e256b474346f69fed7a7b4bfd454e2afe3107bf9.zip
Convert more ports to USES=(tcl|tk):tea
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libimg/Makefile4
-rw-r--r--graphics/tkpng/Makefile10
-rw-r--r--graphics/togl/Makefile11
3 files changed, 3 insertions, 22 deletions
diff --git a/graphics/libimg/Makefile b/graphics/libimg/Makefile
index e2ffbee14bff..81e5e3cf7146 100644
--- a/graphics/libimg/Makefile
+++ b/graphics/libimg/Makefile
@@ -19,7 +19,7 @@ PLIST_SUB+= SHLIB_NAME="${SHLIB_NAME}" \
SHLIB_LINK="${SHLIB_LINK}"
WRKSRC= ${WRKDIR}/tkimg${PORTVERSION:R}
-USES= jpeg tk tar:bzip2
+USES= autoreconf jpeg tk:tea tar:bzip2
# We don't need the bundled libraries:
EXTRACT_AFTER_ARGS= --exclude '*/libz/*' --exclude zlib \
@@ -27,8 +27,6 @@ EXTRACT_AFTER_ARGS= --exclude '*/libz/*' --exclude zlib \
--exclude '*/compat/*' --exclude '*/libtiff/*' \
--exclude '*/libjpeg/*' --exclude '*/libpng/*'
MAKE_ARGS+= INSTALL_ROOT="${STAGEDIR}"
-USE_AUTOTOOLS= autoconf
-CONFIGURE_ARGS= --with-tcl="${TCL_LIBDIR}" --with-tk="${TK_LIBDIR}"
CONFIGURE_ENV= WRKDIR="${WRKDIR}"
post-patch:
diff --git a/graphics/tkpng/Makefile b/graphics/tkpng/Makefile
index abb7b54c59a6..8c136aeb861a 100644
--- a/graphics/tkpng/Makefile
+++ b/graphics/tkpng/Makefile
@@ -16,15 +16,7 @@ LICENSE_NAME= Tcl/Tk License
LICENSE_FILE= ${WRKSRC}/license.terms
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES+= tk tar:tgz
-GNU_CONFIGURE= yes
-
-CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
- --with-tk=${TK_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR} \
- --with-tkinclude=${TK_INCLUDEDIR} \
- --exec-prefix=${PREFIX} \
- --enable-shared
+USES= tk:tea tar:tgz
TKPKG= ${PORTNAME}${PORTVERSION}
PLIST_SUB= VER=${PORTVERSION} TKPKG=${TKPKG} TKLIBVER=${TKLIBVER}
diff --git a/graphics/togl/Makefile b/graphics/togl/Makefile
index c3ee69ffcf61..3a9eb2137adc 100644
--- a/graphics/togl/Makefile
+++ b/graphics/togl/Makefile
@@ -14,22 +14,13 @@ COMMENT= Tk OpenGL widget
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake tk
+USES= gmake tk:tea
USE_XORG= x11 xt xmu
USE_GL= gl
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tk=${TK_LIBDIR} \
- --with-tcl=${TCL_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR}
USE_LDCONFIG= yes
TOGL_INSTDIR= ${PREFIX}/lib/${DISTNAME}
-CPPFLAGS+= -I${TK_INCLUDEDIR}
-LDFLAGS+= -L${TK_LIBDIR}
-
-PLIST_SUB= TK_VER=${TK_VER}
-
OPTIONS_DEFINE= DOCS EXAMPLES
post-patch: