aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-10-22 23:35:25 +0800
committertobik <tobik@FreeBSD.org>2017-10-22 23:35:25 +0800
commite356b6dc5c802f39648b228f67f2b64484da873e (patch)
tree623666867bf77afa74e18658ad2f14b5fde2a603 /graphics
parent1ee05d184e676da3b7e75abfec74e3da37052c66 (diff)
downloadfreebsd-ports-gnome-e356b6dc5c802f39648b228f67f2b64484da873e.tar.gz
freebsd-ports-gnome-e356b6dc5c802f39648b228f67f2b64484da873e.tar.zst
freebsd-ports-gnome-e356b6dc5c802f39648b228f67f2b64484da873e.zip
New port: graphics/pixd
Pixd visualizes binary data by mapping each octet to a colour according to a palette, displaying the octet at a given number of columns per line. WWW: https://github.com/FireyFly/pixd/ PR: 219670 Submitted by: Dhananjay Balan <mail@dbalan.in>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pixd/Makefile28
-rw-r--r--graphics/pixd/distinfo3
-rw-r--r--graphics/pixd/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 15a579d67f11..48d823cc29b4 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -798,6 +798,7 @@
SUBDIR += piglit
SUBDIR += pikopixel
SUBDIR += pinpoint
+ SUBDIR += pixd
SUBDIR += pixelize
SUBDIR += pixen
SUBDIR += pixie
diff --git a/graphics/pixd/Makefile b/graphics/pixd/Makefile
new file mode 100644
index 000000000000..677116be9c45
--- /dev/null
+++ b/graphics/pixd/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= pixd
+PORTVERSION= g20170531
+CATEGORIES= graphics
+
+MAINTAINER= mail@dbalan.in
+COMMENT= Visualize binary data in terminal
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= FireyFly
+GH_TAGNAME= 85c1cb6
+
+ALL_TARGET= pixd
+
+PLIST_FILES= bin/pixd \
+ man/man1/pixd.1.gz
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pixd ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pixd.1 ${STAGEDIR}${PREFIX}/man/man1
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pixd
+
+.include <bsd.port.mk>
diff --git a/graphics/pixd/distinfo b/graphics/pixd/distinfo
new file mode 100644
index 000000000000..f5034f7f7374
--- /dev/null
+++ b/graphics/pixd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1508685926
+SHA256 (FireyFly-pixd-g20170531-85c1cb6_GH0.tar.gz) = 0a2076f8c0bf7268bfce0a1dd0a1779d7f7e040f268b3f0c5b21d4ee2c3fb1af
+SIZE (FireyFly-pixd-g20170531-85c1cb6_GH0.tar.gz) = 207012
diff --git a/graphics/pixd/pkg-descr b/graphics/pixd/pkg-descr
new file mode 100644
index 000000000000..091520dc6110
--- /dev/null
+++ b/graphics/pixd/pkg-descr
@@ -0,0 +1,5 @@
+Pixd visualizes binary data by mapping each octet to a colour
+according to a palette, displaying the octet at a given number of
+columns per line.
+
+WWW: https://github.com/FireyFly/pixd/