aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-28 17:34:32 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-28 17:34:32 +0800
commite3bfd4420b8c16c8a19d047a1b0e2a10a9ff07dd (patch)
treec9850b1527c093db7449592edc38544fe3d81877 /graphics
parentbbdde8f142cc5e38e890072cbf49d86b97ea8d30 (diff)
downloadfreebsd-ports-gnome-e3bfd4420b8c16c8a19d047a1b0e2a10a9ff07dd.tar.gz
freebsd-ports-gnome-e3bfd4420b8c16c8a19d047a1b0e2a10a9ff07dd.tar.zst
freebsd-ports-gnome-e3bfd4420b8c16c8a19d047a1b0e2a10a9ff07dd.zip
- fix check, so png is detected.
Submitted by: tron@freenode
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gd/Makefile2
-rw-r--r--graphics/gd/files/patch-gd_png.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index 8b68ed8dc075..1dbdc85a1396 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gd
PORTVERSION= 2.0.35
-PORTREVISION?= 6
+PORTREVISION?= 7
PORTEPOCH= 1
CATEGORIES+= graphics
MASTER_SITES= http://www.libgd.org/releases/
diff --git a/graphics/gd/files/patch-gd_png.c b/graphics/gd/files/patch-gd_png.c
index 42c677ae41f3..d0af770b29da 100644
--- a/graphics/gd/files/patch-gd_png.c
+++ b/graphics/gd/files/patch-gd_png.c
@@ -5,7 +5,7 @@
}
- if (!png_check_sig (sig, 8)) { /* bad signature */
-+ if (!png_sig_cmp (sig, 0, 8)) { /* bad signature */
++ if (png_sig_cmp (sig, 0, 8)) { /* bad signature */
return NULL; /* bad signature */
}