aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-07-05 05:32:01 +0800
committersteve <steve@FreeBSD.org>1999-07-05 05:32:01 +0800
commite50a27da16ddd9090b0bb26b48d9fa2ae4c4d213 (patch)
treee64d1de83beaeb895280f5ba02745733d63780b9 /graphics
parentaa5056341b49f07e6ab75258435c97e1891bef49 (diff)
downloadfreebsd-ports-gnome-e50a27da16ddd9090b0bb26b48d9fa2ae4c4d213.tar.gz
freebsd-ports-gnome-e50a27da16ddd9090b0bb26b48d9fa2ae4c4d213.tar.zst
freebsd-ports-gnome-e50a27da16ddd9090b0bb26b48d9fa2ae4c4d213.zip
Make this port build with egcs' f77.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-PGPLOT/Makefile12
-rw-r--r--graphics/pgperl/Makefile12
2 files changed, 22 insertions, 2 deletions
diff --git a/graphics/p5-PGPLOT/Makefile b/graphics/p5-PGPLOT/Makefile
index dfe2a17f470b..e95d82047d5f 100644
--- a/graphics/p5-PGPLOT/Makefile
+++ b/graphics/p5-PGPLOT/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 December 1996
# Whom: jmz
#
-# $Id: Makefile,v 1.12 1998/11/11 05:37:20 asami Exp $
+# $Id: Makefile,v 1.13 1998/12/05 03:05:26 jmz Exp $
#
DISTNAME= PGPLOT-2.08
@@ -24,6 +24,16 @@ SCRIPTS_ENV= PERL=${PERL}
MAN3= ExtUtils::F77.3 PGPLOT.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+.if ${OSVERSION} >= 400005
+F2CLIB= -lg2c
+.else
+F2CLIB= -lf2c
+.endif
+
+post-patch:
+ (cd ${WRKSRC}/ExtUtils; mv -f F77.pm F77.pm~; ${SED} -e \
+ 's/@F2CLIB@/${F2CLIB}/g' F77.pm~ > F77.pm)
+
post-install:
@${MKDIR} ${PREFIX}/share/doc/pgperl
@(cd ${WRKSRC}; ${INSTALL_DATA} LICENSE test* \
diff --git a/graphics/pgperl/Makefile b/graphics/pgperl/Makefile
index dfe2a17f470b..e95d82047d5f 100644
--- a/graphics/pgperl/Makefile
+++ b/graphics/pgperl/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 December 1996
# Whom: jmz
#
-# $Id: Makefile,v 1.12 1998/11/11 05:37:20 asami Exp $
+# $Id: Makefile,v 1.13 1998/12/05 03:05:26 jmz Exp $
#
DISTNAME= PGPLOT-2.08
@@ -24,6 +24,16 @@ SCRIPTS_ENV= PERL=${PERL}
MAN3= ExtUtils::F77.3 PGPLOT.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+.if ${OSVERSION} >= 400005
+F2CLIB= -lg2c
+.else
+F2CLIB= -lf2c
+.endif
+
+post-patch:
+ (cd ${WRKSRC}/ExtUtils; mv -f F77.pm F77.pm~; ${SED} -e \
+ 's/@F2CLIB@/${F2CLIB}/g' F77.pm~ > F77.pm)
+
post-install:
@${MKDIR} ${PREFIX}/share/doc/pgperl
@(cd ${WRKSRC}; ${INSTALL_DATA} LICENSE test* \