aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-09-15 06:01:13 +0800
committerJan Beich <jbeich@FreeBSD.org>2019-09-15 06:01:13 +0800
commite5688543b0a7b773d34e63d05359814d3cc70857 (patch)
tree36f0e35aadb76ca2b55eb19335845f4f9ae5476d /graphics
parent002af553a418a4773bd1ae3e8bc6e7ea4cbd85b7 (diff)
downloadfreebsd-ports-gnome-e5688543b0a7b773d34e63d05359814d3cc70857.tar.gz
freebsd-ports-gnome-e5688543b0a7b773d34e63d05359814d3cc70857.tar.zst
freebsd-ports-gnome-e5688543b0a7b773d34e63d05359814d3cc70857.zip
Drop C++11 workaround for GCC < 6 after r449590
lang/gcc5 will expire in ~1 month. If someone still uses lang/gcc48 they should backport C++11 fix instead. QA on GCC architecuters is currently limited to powerpc64 which uses GCC_DEFAULT. PR: 193528
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aseprite/Makefile2
-rw-r--r--graphics/colmap/Makefile2
-rw-r--r--graphics/hiptext/Makefile1
-rw-r--r--graphics/libboard/Makefile1
-rw-r--r--graphics/mapnik/Makefile8
-rw-r--r--graphics/podofo/Makefile8
-rw-r--r--graphics/sekrit-twc-zimg/Makefile2
-rw-r--r--graphics/vapoursynth-waifu2x-w2xc/Makefile2
-rw-r--r--graphics/waifu2x-converter-cpp/Makefile2
9 files changed, 2 insertions, 26 deletions
diff --git a/graphics/aseprite/Makefile b/graphics/aseprite/Makefile
index 7c4e3c9b820a..554aa15ca9f7 100644
--- a/graphics/aseprite/Makefile
+++ b/graphics/aseprite/Makefile
@@ -65,8 +65,6 @@ CMAKE_ON= USE_SHARED_ALLEGRO4 \
USE_SHARED_ZLIB
CMAKE_ARGS= -DFREEBSD_LIB_PATH=${LOCALBASE}/lib
-CXXFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
-
OPTIONS_DEFINE= STEAM WEBP
OPTIONS_DEFAULT= WEBP
diff --git a/graphics/colmap/Makefile b/graphics/colmap/Makefile
index 70ba7affd1b8..b062b7782e8a 100644
--- a/graphics/colmap/Makefile
+++ b/graphics/colmap/Makefile
@@ -34,8 +34,6 @@ USE_QT= qmake_build buildtools_build core gui opengl_build widgets
EXCLUDE= SQLite
EXTRACT_AFTER_ARGS= ${EXCLUDE:S,^,--exclude lib/,}
CMAKE_OFF= BOOST_STATIC CUDA_ENABLED
-CXXFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
- -D_DECLARE_C99_LDBL_MATH # XXX ports/193528
LDFLAGS+= -Wl,--as-needed # gflags, glu, xi, xmu
TEST_TARGET= test ARGS="-V"
diff --git a/graphics/hiptext/Makefile b/graphics/hiptext/Makefile
index 994bcdddd7d4..4d26e0604367 100644
--- a/graphics/hiptext/Makefile
+++ b/graphics/hiptext/Makefile
@@ -25,7 +25,6 @@ GH_ACCOUNT= jart
GH_TAGNAME= f89b44f
USES= compiler:c++11-lib gmake jpeg localbase
-CPPFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
CPPFLAGS+= -I${LOCALBASE}/include/freetype2
MAKE_ENV= GTEST_DIR="${LOCALBASE}" \
TARGET_ARCH=""
diff --git a/graphics/libboard/Makefile b/graphics/libboard/Makefile
index bc67e7764054..c54266f55879 100644
--- a/graphics/libboard/Makefile
+++ b/graphics/libboard/Makefile
@@ -19,7 +19,6 @@ USE_GITHUB= yes
GH_ACCOUNT= c-koi
GH_TAGNAME= 5b38274
-CXXFLAGS+= -D_GLIBCXX_USE_C99 -fPIC # XXX ports/193528
USE_CXXSTD= c++11
CMAKE_ARGS= -DMYPROJ_RAN_ONCE:BOOL=YES \
-DEXECUTABLE_OUTPUT_PATH:PATH="${STAGEDIR}${EXAMPLESDIR}"
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index 9792cf1c6ea6..521d9871ade8 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -80,12 +80,6 @@ CAIRO_LIB_DEPENDS= libcairo.so:graphics/cairo
CAIRO_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:graphics/py-cairo@${PY_FLAVOR}
CAIRO_MAKE_ARGS_OFF= CAIRO=False
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-CXXFLAGS+= -D_GLIBCXX_USE_C99 # gcc c++11 support is broken on FreeBSD
-.endif
-
pre-configure-SQLITE3-on:
@if ! ${LOCALBASE}/bin/sqlite3 :memory: 'create virtual table foo using rtree(pkid, xmin, xmax, ymin, ymax)' > /dev/null 2>&1; then \
${ECHO_MSG} "" ; \
@@ -112,4 +106,4 @@ post-install-DOCS-on:
@cd ${WRKSRC} && ${COPYTREE_SHARE} "AUTHORS.md CHANGELOG.md README.md docs" \
${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 6ca6106ef545..63c7c0d1365e 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -41,14 +41,8 @@ PNG_LIB_DEPENDS= libpng.so:graphics/png
TIFF_CMAKE_BOOL= WANT_TIFF
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} >= 50
-CXXFLAGS+= -std=gnu++11 -D_GLIBCXX_USE_C99=1
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|$${LIBDIRNAME}/pkgconfig|${PREFIX}/libdata/pkgconfig|' ${WRKSRC}/src/CMakeLists.txt
@${REINPLACE_CMD} -e '/^Libs: / s|-@PODOFO_VERSION_MAJOR@||' ${WRKSRC}/src/libpodofo.pc.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/sekrit-twc-zimg/Makefile b/graphics/sekrit-twc-zimg/Makefile
index a422f2b13121..18393b1eeb9b 100644
--- a/graphics/sekrit-twc-zimg/Makefile
+++ b/graphics/sekrit-twc-zimg/Makefile
@@ -20,8 +20,6 @@ CONFLICTS_INSTALL= zimg-[0-9]* # include/zimg.h
USES= autoreconf compiler:c++11-lib gmake libtool pathfix
EXTRACT_AFTER_ARGS= --exclude test/extra
GNU_CONFIGURE= yes
-CPPFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
- -D_DECLARE_C99_LDBL_MATH # XXX ports/193528
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
PORTEXAMPLES= *
diff --git a/graphics/vapoursynth-waifu2x-w2xc/Makefile b/graphics/vapoursynth-waifu2x-w2xc/Makefile
index f6dcc66c10db..d8c7ebc66df0 100644
--- a/graphics/vapoursynth-waifu2x-w2xc/Makefile
+++ b/graphics/vapoursynth-waifu2x-w2xc/Makefile
@@ -21,8 +21,6 @@ GH_PROJECT= VapourSynth-Waifu2x-w2xc
USES= compiler:c++11-lib gmake localbase pkgconfig
HAS_CONFIGURE= yes
-CPPFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
- -D_DECLARE_C99_LDBL_MATH # XXX ports/193528
CONFIGURE_ARGS= --install="${STAGEDIR}${DATADIR}" \
--cxx="${CXX}" \
--extra-cxxflags="${CPPFLAGS} ${CXXFLAGS}" \
diff --git a/graphics/waifu2x-converter-cpp/Makefile b/graphics/waifu2x-converter-cpp/Makefile
index bd695348e9f5..ceb2b2658e01 100644
--- a/graphics/waifu2x-converter-cpp/Makefile
+++ b/graphics/waifu2x-converter-cpp/Makefile
@@ -26,8 +26,6 @@ DOS2UNIX_GLOB= *.cpp *.hpp
CMAKE_ARGS= -DOPENCV_PREFIX:PATH="${LOCALBASE}" \
-DOpenCL_LIBRARY:FILEPATH="${LOCALBASE}/lib/libOpenCL.so"
CMAKE_ON= INSTALL_MODELS
-CFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
- -D_DECLARE_C99_LDBL_MATH # XXX ports/193528
LDFLAGS+= -Wl,--as-needed # avoid overlinking (opencv deps)
TEST_TARGET= test ARGS="-V"
USE_LDCONFIG= yes