aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-04-20 10:31:21 +0800
committerjbeich <jbeich@FreeBSD.org>2018-04-20 10:31:21 +0800
commite812224dfdfe9eb0b581fd70d77add65c9fe7d0d (patch)
tree1b3f5cd0590884fc78e3af2cb852d58803c9eb93 /graphics
parente309800b6491a9e37442f35c52ee6ab017443eef (diff)
downloadfreebsd-ports-gnome-e812224dfdfe9eb0b581fd70d77add65c9fe7d0d.tar.gz
freebsd-ports-gnome-e812224dfdfe9eb0b581fd70d77add65c9fe7d0d.tar.zst
freebsd-ports-gnome-e812224dfdfe9eb0b581fd70d77add65c9fe7d0d.zip
graphics/pcl-pointclouds: unbreak with boost 1.67
In file included from /wrkdirs/usr/ports/graphics/pcl-pointclouds/work/pcl-pcl-1.8.1/outofcore/tools/outofcore_process.cpp:53: In file included from /wrkdirs/usr/ports/graphics/pcl-pointclouds/work/pcl-pcl-1.8.1/outofcore/include/pcl/outofcore/outofcore_impl.h:50: /wrkdirs/usr/ports/graphics/pcl-pointclouds/work/pcl-pcl-1.8.1/outofcore/include/pcl/outofcore/impl/octree_disk_container.hpp:77:74: error: no matching constructor for initialization of 'boost::uuids::random_generator' (aka 'boost::uuids::random_generator_pure') boost::uuids::random_generator OutofcoreOctreeDiskContainer<PointT>::uuid_gen_ (&rand_gen_); ^ ~~~~~~~~~~ /usr/local/include/boost/uuid/random_generator.hpp:149:7: note: candidate constructor (the implicit copy constructor) not viable: no known conversion from 'boost::mt19937 *' (aka 'mersenne_twister_engine<unsigned int, 32, 624, 397, 31, 2567483615U, 11, 4294967295U, 7, 2636928640U, 15, 4022730752U, 18, 1812433253> *') to 'const boost::uuids::random_generator_pure' for 1st argument class random_generator_pure ^ /usr/local/include/boost/uuid/random_generator.hpp:149:7: note: candidate constructor (the implicit default constructor) not viable: requires 0 arguments, but 1 was provided PR: 227427 Reported by: antoine (via exp-run) Obtained from: Homebrew
Diffstat (limited to 'graphics')
-rw-r--r--graphics/pcl-pointclouds/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/pcl-pointclouds/Makefile b/graphics/pcl-pointclouds/Makefile
index 28985e351450..9580cf6d5a18 100644
--- a/graphics/pcl-pointclouds/Makefile
+++ b/graphics/pcl-pointclouds/Makefile
@@ -13,8 +13,6 @@ COMMENT= Point Cloud Library
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN= https://github.com/PointCloudLibrary/pcl/issues/2284
-
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libexpat.so:textproc/expat2 \
libflann_cpp.so:math/flann \
@@ -30,6 +28,9 @@ USE_GL= gl glu
USE_XORG= x11 xext xt ice sm
USE_LDCONFIG= yes
+# https://github.com/PointCloudLibrary/pcl/issues/2284
+CXXFLAGS+= -DBOOST_UUID_RANDOM_GENERATOR_COMPAT
+
PLIST_SUB= SHL3=${DISTVERSION} SHL2=${DISTVERSION:R}
DATADIR= ${PREFIX}/share/${PORTNAME}-${DISTVERSION:R} # match the directory where the project installs .cmake files