aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-06-01 21:13:15 +0800
committerkrion <krion@FreeBSD.org>2004-06-01 21:13:15 +0800
commite87f5ab21ad7cd31e803777ede87cb930c35aaf0 (patch)
tree73ffb16a59616f92bf27593e0bf98e0815783db1 /graphics
parent5d66e9aa2532995c69108c66a6df38fb68bff301 (diff)
downloadfreebsd-ports-gnome-e87f5ab21ad7cd31e803777ede87cb930c35aaf0.tar.gz
freebsd-ports-gnome-e87f5ab21ad7cd31e803777ede87cb930c35aaf0.tar.zst
freebsd-ports-gnome-e87f5ab21ad7cd31e803777ede87cb930c35aaf0.zip
Add corona 1.0.2,
Corona is an image input/output library that can read, write, and manipulate image files in just a few lines of code. It can write PNG and TGA files, and read PNG, JPEG, PCX, BMP, TGA, and GIF. Corona was designed to be easy to use, and exports a straightforward C++ API. With just a few lines of C++, you can add image loading to your application. PR: ports/67433 Submitted by: David Yeske <dyeske@yahoo.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/corona/Makefile40
-rw-r--r--graphics/corona/distinfo2
-rw-r--r--graphics/corona/pkg-descr11
-rw-r--r--graphics/corona/pkg-plist6
5 files changed, 60 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d9e04b4dd079..98e0d6549327 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -35,6 +35,7 @@
SUBDIR += cinepaint
SUBDIR += claraocr
SUBDIR += compupic
+ SUBDIR += corona
SUBDIR += cqcam
SUBDIR += crw
SUBDIR += cthumb
diff --git a/graphics/corona/Makefile b/graphics/corona/Makefile
new file mode 100644
index 000000000000..90ee6787559f
--- /dev/null
+++ b/graphics/corona/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: corona
+# Date created: 25 May 2004
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+
+PORTNAME= corona
+PORTVERSION= 1.0.2
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dyeske@yahoo.com
+COMMENT= A graphics library that supports most image formats
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ ungif.5:${PORTSDIR}/graphics/libungif
+
+GNU_CONFIGURE= yes
+USE_GNOME= gnometarget lthack
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 500000
+BROKEN= "Bad C++ code"
+.endif
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LIBS="${LIBS} -L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-Wall||' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/graphics/corona/distinfo b/graphics/corona/distinfo
new file mode 100644
index 000000000000..943d234abfd0
--- /dev/null
+++ b/graphics/corona/distinfo
@@ -0,0 +1,2 @@
+MD5 (corona-1.0.2.tar.gz) = 29d1a7f1e2c85a83e9620496c62740ce
+SIZE (corona-1.0.2.tar.gz) = 233675
diff --git a/graphics/corona/pkg-descr b/graphics/corona/pkg-descr
new file mode 100644
index 000000000000..41c33e874941
--- /dev/null
+++ b/graphics/corona/pkg-descr
@@ -0,0 +1,11 @@
+Corona is an image input/output library that can read, write, and
+manipulate image files in just a few lines of code. It can write
+PNG and TGA files, and read PNG, JPEG, PCX, BMP, TGA, and GIF.
+Corona was designed to be easy to use, and exports a straightforward
+C++ API. With just a few lines of C++, you can add image loading
+to your application.
+
+WWW: http://corona.sourceforge.net/
+
+- David
+dyeske@yahoo.com
diff --git a/graphics/corona/pkg-plist b/graphics/corona/pkg-plist
new file mode 100644
index 000000000000..40feabaa7216
--- /dev/null
+++ b/graphics/corona/pkg-plist
@@ -0,0 +1,6 @@
+bin/corconvert
+bin/corona-config
+include/corona.h
+lib/libcorona-1.0.2.so
+lib/libcorona.a
+lib/libcorona.so