aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-15 20:41:00 +0800
committeredwin <edwin@FreeBSD.org>2003-10-15 20:41:00 +0800
commitea4856cb3670275430cd8607f77010396d914535 (patch)
tree89232377f9abb9a836189bbc3a46abfedc9bfd10 /graphics
parent1c171b75db036a89b57f270e39717f130b24f59e (diff)
downloadfreebsd-ports-gnome-ea4856cb3670275430cd8607f77010396d914535.tar.gz
freebsd-ports-gnome-ea4856cb3670275430cd8607f77010396d914535.tar.zst
freebsd-ports-gnome-ea4856cb3670275430cd8607f77010396d914535.zip
unbreak port:
- force to use python 2.2 - make port localbase/x11base clean noticed by: bento/kris Informed maintainer.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/blender-devel/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/graphics/blender-devel/Makefile b/graphics/blender-devel/Makefile
index a99d3209ecaa..dd675393b265 100644
--- a/graphics/blender-devel/Makefile
+++ b/graphics/blender-devel/Makefile
@@ -13,8 +13,6 @@ PKGNAMESUFFIX= -devel
MAINTAINER= dyeske@yahoo.com
COMMENT= 3D modeling/rendering/animation/gaming package
-BROKEN= "Does not compile (different error on 4.x and 5.x)"
-
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
nspr4.1:${PORTSDIR}/devel/nspr \
openal.0:${PORTSDIR}/audio/openal \
@@ -25,6 +23,7 @@ USE_BZIP2= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_PYTHON= yes
+PYTHON_VERSION= python2.2
USE_MESA= yes
.if defined(WITH_OPTIMIZED_CFLAGS)
@@ -81,6 +80,10 @@ post-patch:
's|\$$(NAN_LIBDIR)/\$$(CONFIG_GUESS)|\$$(NAN_LIBDIR)|; \
s|\$$(NAN_OBJDIR)/\$$(CONFIG_GUESS)|\$$(NAN_OBJDIR)|' \
${WRKSRC}/source/nan_definitions.mk
+ @${REINPLACE_CMD} -e \
+ 's,/usr/local,${LOCALBASE},g; \
+ s,/usr/X11R6,${X11BASE},g' \
+ ${WRKSRC}/source/*.mk
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/obj/bin/blender ${PREFIX}/bin