aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-09-02 13:11:37 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2019-09-02 13:11:37 +0800
commitea763aa5628141b372727bdd271d6ad7013e9671 (patch)
tree68fb96ae3a84c81f6f3d10e56b6118585e442988 /graphics
parent0def901fc20a535ffa14e3ef4c6a492aa8a169b3 (diff)
downloadfreebsd-ports-gnome-ea763aa5628141b372727bdd271d6ad7013e9671.tar.gz
freebsd-ports-gnome-ea763aa5628141b372727bdd271d6ad7013e9671.tar.zst
freebsd-ports-gnome-ea763aa5628141b372727bdd271d6ad7013e9671.zip
New port: graphics/png++: C++ wrapper for libpng library
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/png++/Makefile20
-rw-r--r--graphics/png++/distinfo3
-rw-r--r--graphics/png++/files/patch-Makefile25
-rw-r--r--graphics/png++/pkg-descr4
-rw-r--r--graphics/png++/pkg-plist29
6 files changed, 82 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 56f64aa87273..7a3a0d0ab918 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -778,6 +778,7 @@
SUBDIR += plasma-kmod
SUBDIR += plotutils
SUBDIR += png
+ SUBDIR += png++
SUBDIR += png2html
SUBDIR += png2ico
SUBDIR += pngcheck
diff --git a/graphics/png++/Makefile b/graphics/png++/Makefile
new file mode 100644
index 000000000000..a09ad0ef2a4a
--- /dev/null
+++ b/graphics/png++/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= png++
+DISTVERSION= 0.2.9
+CATEGORIES= graphics
+MASTER_SITES= http://download.savannah.nongnu.org/releases/pngpp/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ wrapper for libpng library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= png>0:graphics/png
+
+USES= gmake
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/png++/distinfo b/graphics/png++/distinfo
new file mode 100644
index 000000000000..3e2bce794bbb
--- /dev/null
+++ b/graphics/png++/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1567398167
+SHA256 (png++-0.2.9.tar.gz) = abbc6a0565122b6c402d61743451830b4faee6ece454601c5711e1c1b4238791
+SIZE (png++-0.2.9.tar.gz) = 592770
diff --git a/graphics/png++/files/patch-Makefile b/graphics/png++/files/patch-Makefile
new file mode 100644
index 000000000000..734936eb3f96
--- /dev/null
+++ b/graphics/png++/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig 2015-10-25 19:42:45 UTC
++++ Makefile
+@@ -47,18 +47,18 @@ dist_files := $(build_files) $(doc_files) \
+ $(headers) $(sources)
+ dist_subdirs := example test
+
+-all: examples
++all:
+
+ install: install-headers install-docs
+
+ uninstall: uninstall-headers uninstall-docs
+
+ install-headers:
+- mkdir -p $(PREFIX)/include/png++
+- cp $(headers) $(PREFIX)/include/png++
++ mkdir -p $(DESTDIR)$(PREFIX)/include/png++
++ cp $(headers) $(DESTDIR)$(PREFIX)/include/png++
+
+ uninstall-headers:
+- rm -rf $(PREFIX)/include/png++
++ rm -rf $(DESTDIR)$(PREFIX)/include/png++
+
+ dist: dist-mkdir dist-copy-files dist-package
+
diff --git a/graphics/png++/pkg-descr b/graphics/png++/pkg-descr
new file mode 100644
index 000000000000..238930dde3b7
--- /dev/null
+++ b/graphics/png++/pkg-descr
@@ -0,0 +1,4 @@
+PNG++ aims to provide simple yet powerful C++ interface to libpng, the PNG
+reference implementation library.
+
+WWW: https://www.nongnu.org/pngpp/
diff --git a/graphics/png++/pkg-plist b/graphics/png++/pkg-plist
new file mode 100644
index 000000000000..1f59c52d2ac5
--- /dev/null
+++ b/graphics/png++/pkg-plist
@@ -0,0 +1,29 @@
+include/png++/color.hpp
+include/png++/config.hpp
+include/png++/consumer.hpp
+include/png++/convert_color_space.hpp
+include/png++/end_info.hpp
+include/png++/error.hpp
+include/png++/ga_pixel.hpp
+include/png++/generator.hpp
+include/png++/gray_pixel.hpp
+include/png++/image.hpp
+include/png++/image_info.hpp
+include/png++/index_pixel.hpp
+include/png++/info.hpp
+include/png++/info_base.hpp
+include/png++/io_base.hpp
+include/png++/packed_pixel.hpp
+include/png++/palette.hpp
+include/png++/pixel_buffer.hpp
+include/png++/pixel_traits.hpp
+include/png++/png.hpp
+include/png++/reader.hpp
+include/png++/require_color_space.hpp
+include/png++/rgb_pixel.hpp
+include/png++/rgba_pixel.hpp
+include/png++/solid_pixel_buffer.hpp
+include/png++/streaming_base.hpp
+include/png++/tRNS.hpp
+include/png++/types.hpp
+include/png++/writer.hpp