aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2001-08-23 17:20:03 +0800
committerkris <kris@FreeBSD.org>2001-08-23 17:20:03 +0800
commiteb9713f920a4f904f89f9572b5f0bc3749410ad6 (patch)
tree7cafd34d174527536b90ef077419c221a5a64201 /graphics
parent4796223231a3b048ff5ec70256cb7c13c7dfa17d (diff)
downloadfreebsd-ports-gnome-eb9713f920a4f904f89f9572b5f0bc3749410ad6.tar.gz
freebsd-ports-gnome-eb9713f920a4f904f89f9572b5f0bc3749410ad6.tar.zst
freebsd-ports-gnome-eb9713f920a4f904f89f9572b5f0bc3749410ad6.zip
Fix a minor Y2K problem in displaying dates.
Obtained from: OpenBSD Approved by: maintainer
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gtksee/Makefile1
-rw-r--r--graphics/gtksee/files/patch-ab20
2 files changed, 21 insertions, 0 deletions
diff --git a/graphics/gtksee/Makefile b/graphics/gtksee/Makefile
index fd59f751dccc..b4ed056c0686 100644
--- a/graphics/gtksee/Makefile
+++ b/graphics/gtksee/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtksee
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.linux.tucows.com/files/x11/graphics/ \
http://www.physik.TU-Berlin.DE/~ibex/ports/distfiles/
diff --git a/graphics/gtksee/files/patch-ab b/graphics/gtksee/files/patch-ab
new file mode 100644
index 000000000000..2918ea5b22f9
--- /dev/null
+++ b/graphics/gtksee/files/patch-ab
@@ -0,0 +1,20 @@
+--- src/gtksee.c.orig Sat Sep 25 01:27:40 1999
++++ src/gtksee.c Sun May 6 13:25:31 2001
+@@ -322,13 +322,13 @@
+ }
+ if (hour == 0)
+ {
+- sprintf(buffer, "%s, %02i/%02i/%02i 12:%02i AM",
+- text, time->tm_year, time->tm_mon+1, time->tm_mday,
++ sprintf(buffer, "%s, %04i/%02i/%02i 12:%02i AM",
++ text, time->tm_year + 1900, time->tm_mon+1, time->tm_mday,
+ time->tm_min);
+ } else
+ {
+- sprintf(buffer, "%s, %02i/%02i/%02i %02i:%02i %s",
+- text, time->tm_year, time->tm_mon+1, time->tm_mday,
++ sprintf(buffer, "%s, %04i/%02i/%02i %02i:%02i %s",
++ text, time->tm_year + 1900, time->tm_mon+1, time->tm_mday,
+ hour, time->tm_min, (time->tm_hour<12)?"AM":"PM");
+ }
+ g_free(text);