aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-08-09 16:53:57 +0800
committerantoine <antoine@FreeBSD.org>2014-08-09 16:53:57 +0800
commiteb9cb08bfab41884714d1f9386059062b74b79c4 (patch)
tree18c14330f232fd5ef3d9fb793a3a339fd5c808b0 /graphics
parentbe9ec5219dd434fc0778b711ae2b2034827fe5e5 (diff)
downloadfreebsd-ports-gnome-eb9cb08bfab41884714d1f9386059062b74b79c4.tar.gz
freebsd-ports-gnome-eb9cb08bfab41884714d1f9386059062b74b79c4.tar.zst
freebsd-ports-gnome-eb9cb08bfab41884714d1f9386059062b74b79c4.zip
Mark BROKEN: fails to build
/bin/sh ../libtool --tag=CXX --mode=compile c++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"IccXML\" -DVERSION=\"0.9.6\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DSTDC_HEADERS=1 -DHAVE_LIMITS_H=1 -DHAVE_UNISTD_H=1 -DHAVE_STRERROR=1 -I. -I.. -I../IccXML -I/usr/local/include/SampleICC -I/usr/local/include/libxml2 -I/usr/local/include -O2 -pipe -fno-strict-aliasing -MT IccMpeXml.lo -MD -MP -MF .deps/IccMpeXml.Tpo -c -o IccMpeXml.lo IccMpeXml.cpp libtool: compile: c++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"IccXML\" -DVERSION=\"0.9.6\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DSTDC_HEADERS=1 -DHAVE_LIMITS_H=1 -DHAVE_UNISTD_H=1 -DHAVE_STRERROR=1 -I. -I.. -I../IccXML -I/usr/local/include/SampleICC -I/usr/local/include/libxml2 -I/usr/local/include -O2 -pipe -fno-strict-aliasing -MT IccMpeXml.lo -MD -MP -MF .deps/IccMpeXml.Tpo -c IccMpeXml.cpp -fPIC -DPIC -o .libs/IccMpeXml.o In file included from IccMpeXml.cpp:65: IccUtilXml.h:197:23: warning: no newline at end of file In file included from IccMpeXml.cpp:65: IccUtilXml.h:73: error: redefinition of 'class CIccUTF16String' /usr/local/include/SampleICC/IccUtil.h:317: error: previous definition of 'class CIccUTF16String' IccUtilXml.h:112: error: default argument given for parameter 3 of 'const char* icUtf16ToUtf8(std::string&, const icUInt16Number*, int)' /usr/local/include/SampleICC/IccUtil.h:354: error: after previous specification in 'const char* icUtf16ToUtf8(std::string&, const icUInt16Number*, int)' IccUtilXml.h:113: error: default argument given for parameter 3 of 'const short unsigned int* icUtf8ToUtf16(CIccUTF16String&, const char*, int)' /usr/local/include/SampleICC/IccUtil.h:355: error: after previous specification in 'const short unsigned int* icUtf8ToUtf16(CIccUTF16String&, const char*, int)' gmake[1]: *** [IccMpeXml.lo] Error 1 Reported by: pkg-fallout
Diffstat (limited to 'graphics')
-rw-r--r--graphics/iccxml/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/iccxml/Makefile b/graphics/iccxml/Makefile
index 1232dec708dd..2b4fa61eed2d 100644
--- a/graphics/iccxml/Makefile
+++ b/graphics/iccxml/Makefile
@@ -10,6 +10,8 @@ DISTNAME= IccXML-${PORTVERSION}
MAINTAINER= bsam@FreeBSD.org
COMMENT= Tools for reading and writing the ICC profile contents as XML files
+BROKEN= Fails to build with sampleicc 1.6.8
+
LIB_DEPENDS= libSampleICC.so:${PORTSDIR}/graphics/sampleicc
USES= gmake pathfix pkgconfig libtool